News:

Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: Sn9c253 camera  (Read 9481 times)

May 08, 2011, 06:06:52 pm
Hello,

A friend bought a dealextreme camera, tried to flash it with Foscam´s firmware, and the obvious bricking happened.

After much fiddling, I understood and detected that the camera sensor is a Sn9C253,  ( 0xc45 / 0x62f1  ).
I´ve tried a lot of firmwares, but none worked. They always get the "camera" executable to reboot when it cannot communicate with the sensor. I believe it to be the same as a Wansview NC541/W, but didn´t find the firmware for that model also.

Do anybody have a firmware from a camera with this same sensor, or , failing that, how can I compile this module and insert it into a firmware ?

Thanks for the help.

  • No avatar
  • *****
May 10, 2011, 08:53:26 am
How much flash do you have?

Firmware wise - I have an EXTENSIVE collection up in /files, browse...


  • *****
May 10, 2011, 02:09:28 pm
I now have good firmware files for the Wansview NC541/W. I am out of town right now but I will upload next week, at the latest.

May 10, 2011, 07:38:40 pm
Hi, this is the bootlog :  I believe 4MB.


W90P745 Boot Loader [ Version 1.1 $Revision: 1 $ ] Rebuilt on May 11 2010
Memory Size is 0x1000000 Bytes, Flash Size is 0x400000 Bytes
Board designed by Winbond
Hardware support provided at Winbond
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.
Boot Loader Configuration:

        MAC Address         : 00:B8:00:00:07:31
        IP Address          : 0.0.0.0
        DHCP Client         : Enabled
        CACHE               : Enabled
        BL buffer base      : 0x00300000
        BL buffer size      : 0x00100000
        Baud Rate           : -1
        USB Interface       : Disabled
        Serial Number       : 0xFFFFFFFF


I think I tried most of them. Many will stop in the Calibrating Delay Loop, others will load but cause the camera to reboot with the "write i2c error".

Using your ram-loadable firmware, I could determine the ID that the firmware was seeing in the USB identification of the camera sensor, but don´t know if is there a way to change the id the driver uses, or how to determine from the firmware file which sensor it supports.

Thanks.

  • No avatar
  • *****
May 14, 2011, 04:28:37 am
if it's a foscam 8909 clone you may try to download the apexis APM-J011-WS fw.
they seem to have various drivers compiled in.

May 25, 2011, 07:36:20 pm
Hi,

Did not work. Same i2c write error when the camera executable doesn´t find the USB ID of the camera.

Do somebody has a firmware that recognize this ID, or is there a way to change the ID in the Camera EEPROM or something ?

Thanks,

  • *****
May 26, 2011, 12:08:46 am
I don't think that the Wansview firmware will help you:
Code: [Select]
...
new USB device :80fb4004-fed740

hub.c: new USB device 1, assigned address 2

probing sonix288 usb camera

dvm camera registered as video0

...
new USB device :80fb4404-fed740

hub.c: new USB device 2, assigned address 3

idVendor = 0x148f, idProduct = 0x2573
...

  • No avatar
  • *****
May 26, 2011, 03:47:47 pm
Hi,
can it be that your friend bought the maygion type camera?
Does the connector for the powersupply say 12V?

May 26, 2011, 06:59:09 pm
Celem,

I believed it could work based in pictures / the code 541CPU-B in the board. Saw that you posted the firmware, will try until the weekend and see.

Schufti,

Is is a 5V 1.5A. Does this Maygion looks like a Foscam, and, more importantly, does it have a firmware to download somewhere ?
Thanks.

  • No avatar
  • *****
May 27, 2011, 06:26:41 am
Hi,
yes the maygion does look like the foscam, but AFAIK they are 12V (like some 1st gen foscam?).

see here for details
http://www.gadgetvictims.com/2011/01/chinese-ptz-ip-cameras.html#comments

here someone had exactly the same problem
http://www.computersolutions.cn/blog/category/ip-cam/