News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - schufti

Pages: [1] 2 3 ... 36
1
General Discussion / Re: Neo Coolcam Bricked, Need Help
« on: February 11, 2016, 02:53:58 am »
hmmm, from the bootlog I would say that the ethernet is initialized but it is missing from the ifconfig listing. Did you have an ethernet cable attached during boot?

you'll have to search the forum for "ralink" to see if there is some info on how to flash firmware via bootloader on these models. I don't have firmware or info for them, just in general on embedded linux and hw.

2
General Discussion / Re: Neo Coolcam Bricked, Need Help
« on: February 10, 2016, 03:15:56 am »
Hi,
I think you just have to press "4" to access the bootloader commandline.

but I would try to access the running system frist. There should be a command shell open on the serial, so you should be able to check the network configuration ...

3
General Discussion / Re: Neo Coolcam Bricked, Need Help
« on: February 08, 2016, 08:00:33 am »
no, if you are able to count you'll see a difference of 4(2) pins.
The one in your document is called 38 pin (but only 36 are fitted).
Yours has 40 pins, whereas the base board only has 38 pins.
The two pins I reference are the ones at the end covered partly by the grey antenna cable.
additionaly the pcb in your document has different component layout...

but if your pcb has the two Rx/Tx points on the back too, lucky you!

4
General Discussion / Re: Neo Coolcam Bricked, Need Help
« on: February 04, 2016, 02:37:08 am »
AFAIR the serial Rx/Tx are the two unsused (free air) pins from the daughterboard.
gnd must be taken from obvious (bare copper "rectangle shaped strip" where shield should be soldered) gnd on daughterboard.

apart from J2 all points you tried were just unpopulated components
D=diode Y=crystal L=inductance

5
Help / Re: Camera stopped working how recovering telnet?
« on: December 03, 2015, 05:38:40 am »
no, in general there is no risk involved connecting the input of the serial2usb converter to any pin, except ones with more than 3V3 (logic) level, but that would most probably only damage your converter.

You only connect gnd, Tx and Rx, 3V3 will not be connected at all. The cam has its own 3V3 supply as has the converter.

The oscilloscope would just have made it easier to find "output" pins..

6
Help / Re: Camera stopped working how recovering telnet?
« on: December 02, 2015, 04:44:09 am »
I'd try C-Tx and C-Rx first, then Rx and Tx allways in relation to gnd.
It would be easier if you have an oscilloscope.
Initially I would just connect the input of my serial port sequentially to the four pins and see if there is any "intelligible" output.
Beware that this is 3V3 Logic, so you need a converter (RS232 or USB whatever you have).

7
Hacking & Modding / Re: Where are the web files?
« on: October 01, 2015, 02:18:00 am »
having read your other posts, I can only recommend to shell out the USD 3 for a USB to serial converter if you really want to do some serious development on these things ...

8
Firmware / Re: Firmware Recovery - method #2
« on: September 30, 2015, 04:21:43 am »
as far as I remember there were some statements that the free Windows version doesn't work, but the trialversion of the commercial kermit will. YMMV

9
Help / Re: I can't identify my camera
« on: September 25, 2015, 02:59:19 am »
depending on the web-ui and the cam-finder sw the UID might be some identification that you can define yourself in the settings.
For beeing accessible from "outside" you mostlikely need portforwarding set up in your wifi router.

10
Help / Re: 7Links PX-3615 - 675 with open video device error
« on: September 17, 2015, 02:04:35 am »
Hi,
unfortunately all the initialization, serverstarts and such happen in one big binary blob.
Somewhere on the board one can find a little documentation of attempts to reverse engineer that up to the level of disassemled machinecode. If you are brave (and lucky) you can patch the video init away.
Or you try to transplant a camera module from a cheap fleamarket shot.

p.s.: and yes, it is apexis (OEM or b-grade)

11
Help / Re: 7Links PX-3615 - 675 with open video device error
« on: September 14, 2015, 03:00:03 am »
Hi,
yes you can connect the sensorboard directly to a PC via usb.

look for some of my very first posts, there should be some with the same board mentioned accompanied by fitting fw (maybe also whole flash dumps, I'm sure I still have them)

12
Help / Re: [FOSCAM] 2 cameras with same MAC address after flash?
« on: August 27, 2015, 02:25:44 am »
Hi,
wich type of backup did you do? via gui?
Have a look at the file with a hex-editor and search for the actually used mac.
Change it and try flashing this modified abckup.

13
not with a budget related to the value of the cam....

15
you can't just pick some fw you like and flash it ?!?!?

a) it has to be for the correct paltform (cpu) and
b) for (mostly) similar hardware.

your cpu is ralink rt5350 (rare piece)
your hw is ???? (could be newer megapixel or older magion, but still highly incompatible with most fw on this board)

Pages: [1] 2 3 ... 36