News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Author Topic: Camera not working  (Read 18948 times)

November 17, 2011, 01:23:08 pm
Awesome news about the romfs.... i guess.
I have to admit, I know nothing about linux.
If hte romfs and webui are good, and the only issue was that the boot_info was put on top of some linux stuff - what is the likelihood that I can find a compatable linux dump?

plus, Im going to try and buzz out the pins again, but cant to any soldering until tomorrow now.

  • No avatar
  • *****
November 17, 2011, 02:46:48 pm
Hi,

good news again. The webui is ok as well. It is branded as "Storage options"

It definitely is a rebranded EasyN webcam, most likely a FS-613x-xxx for which we have firmware in the files section. I'd start with the newest (don't care it is for the ir-cut model) and flash the linux.zip (don't unzip!) if it boots ok, reflash the fw and webui via webui.

Storage Options don't offer fw on their webpage, but the usermanual shows
fw: 4.22.2.32  webui: 4.5.3.44

files in file section are fw: 4.22.2.36  webui: 4.5.3.45
« Last Edit: November 17, 2011, 02:59:35 pm by schufti »

November 17, 2011, 04:39:58 pm
do I need to flash both the romfs.img and linux.zip files

  • No avatar
  • *****
November 18, 2011, 01:28:55 am
hi,

for a start the linux.zip should be enough. after flashing the 2nd "boot info" image shuold be gone.
to have the latest fw fitting th elinux.zip you could later on flash the romfs.img via serial or the full fw via webui.

November 18, 2011, 05:30:11 am
I've got some good news of my own - I downloaded the easyN camera firmware linux.zip and romfs.img, and sent the extracted linux.bin to 0x8000 (sdram) - and that seems to have worked in that the green light was flashing on the front, and it resolved an IP address.
For some reason it didnt use our DHCP server, and so I've yet to verify the actual full functionality but it definitely seems promising.

Now on to the bad news, I still cant get the BOOT_INFO region to work again. As far as I can tell the pins have full connectivity - but when the camera boots it brings up the "ERROR: Unknown data", and it seems to freeze when unzipping image 7 (instead of just failing as it did before).
Also, when I use hte "set" command it freezes too.

Do you think it is worth trying the program the flash with the linux.zip - and conceed defeat on the BOOT_INFO?
The camera doesnt seem to think that the BOOT_INFO is missing, as although it is full with FF's, the one on 0x7f030000 is currently still there, and it appears in the "LS" as appearing in 0x7f010000
My assumption is that the presence of the BOOT_INFO in the wrong location is causing all sorts of issues.

  • No avatar
  • *****
November 18, 2011, 06:09:24 am
hmm, I would try "del 0" to clear the boot info area and have the BL build a new one.

at boot it should bring sth like:
Code: [Select]
WARNING: Image 0 was not found. Try to create one ....Image 0 created If this doesn't take, nothing else will I'm afraid...

If it does, either flash back your bootinfo from the dump
Code: [Select]
fx 0 "BOOT INFO" 0x7F010000 0x7F010000 -for use
Code: [Select]
set -mac0 [MAC] to recover MAC etc.

November 18, 2011, 06:36:09 am
I tried the "del 0" and it says it deletes it - but then typing in LS lists it again, and when it reboots it doesnt say anything about rebuilding.

  • No avatar
  • *****
November 18, 2011, 09:25:08 am
ok, so it finds the 2nd one. So

a) try to del 0 again.

or if this doesn't help

b) "go for gold" and flash the linux.zip
this will clear the 2nd bootinfo for good and maybe solve your mainproblem too.

Maybe we are to cautious and the BL is protected in the flash (possible, but not mandatory)

November 18, 2011, 12:07:04 pm
So I took the plunge and flashed linux.zip and romfs.img,
now I am getting the write i2c error.

progress at least

  • No avatar
  • *****
November 18, 2011, 05:31:08 pm
so it's booting, loading and decompressing the kernel and firing up linux without hickup.

then the dreaded  i2c writing error?

There are several possibilities to try:

if not done allready reflash the old bootinfo

reflash the old romfs (attaced). Since the error comes from the camera binary that resides in the romfs this may be a solution...

allthough I'm pretty sure the 613B fw should be ok for your cam. The webui was exactly the version from the Storage Options userguide: 4.5.3.44, so I don't doubt the fw would have been the 4.22.2.32 perfectly fitting the 613B fw schema, you could try the 613A fw (attaced)

email Storage Options for the orig. fw
« Last Edit: November 18, 2011, 05:34:22 pm by schufti »

November 18, 2011, 06:18:57 pm
schufti - I've just emailed storage options for orignal firmware - so we'll see how helpful they plan on being.
I cant remember which of the EasyN files worked as I tried them all - I will try them all again.
Just to clarify, did you mean the ones in /files/Firmware/EASYN IR FS613B-M1661/, or /files/Firmware/EasyNP/split/

I started working my way down the all the firmwares, and the one from hootoo "works" but it doesnt allow me my old DDNS stuff - so I'll keep trying.

I dont think I've thanked you enough

  • No avatar
  • *****
November 18, 2011, 06:36:33 pm
hi,

the ddns stuff is in the romfs. So if the linux.zip from hootoo works for you, try combining it with your original romfs. For a start keep your old webui or at max use the newer one from EasyN.

!!! Don't use EasyN webui with non EasyN romfs !!! (EasyN webui checks for romfs version and will bail out if not starting with 4.x.x.x)

The /files/Firmware/EasyNP/split/ are the old ones for 613A (which I think are not good for your cam)

The /files/Firmware/EASYN IR FS613B-M1661/ are the new ones for 613B but don't use the "unknown" which are kind of fake.

November 18, 2011, 06:45:01 pm
so Iv'e used the linux.zip from the 613a_linux_romfs.zip and the romfs.bin and webui.bin from the stor_opi.zip .....

and the thing booted up fine. but the website isnt working :(
It shows a pink screen and 404 not found, with the serial terminal saying "do_file: can not find file index.hml"

  • No avatar
  • *****
November 19, 2011, 04:56:09 am
hmmm, that's interesting. how did you flash the webui?

it's a 4MB device, with the original (4MB) romfs and the webui at the correct address (usually there is a different error message in the console window if the webui is at the wrong address)
the hootoo fw is also for 4MB devices and did work ... so maybe try the hootoo linux with the orig romfs and webui or .... combinations galore.

is one of the cam identifying programms able to detect the cam?
then try to flash the webui with it.

wich linux.zip / romfs gave you the i2c errors?

November 22, 2011, 04:19:02 am
schufti - So unfortunatly as the camera was actually my father-in-laws I never got the opportunity to fully complete the fix back to factory condition.
I had used HooToo's uCLinux, and my original romfs.bin and webui.bin files to build up a semi-working camera. He could use StorageOptions' custom controller software to view the video stream and control the pan/tilt, and was not too bothered by the lack of a web interface.
I was not entirely happy with the solution, but it got him what he wanted. I let him know that if he missed the web interface or the DDNS stuff then I would try again - so we'll just see how that goes on.

many thanks again for all your help - I really couldnt have done it without you.
steaky
www.steaky.co.uk