News:

Added a Wiki, please help to add pages to the wiki! - http://wiki.openipcam.com

Author Topic: Can't connect to IP Camera (firmware by MayGion) bought on Dealextreme SKU#29014  (Read 33643 times)

August 24, 2011, 08:22:54 AM
Hello,

I hope you can help me with a problem I have with an IP Camera (firmware by MayGion) that I bought from DealExtreme SKU#29014 (http://www.dealextreme.com/p/ip-wireless-wifi-lan-camera-with-night-vision-and-pan-tilt-motors-29014).

The scenario I had is as follow:
  • I installed the IP Camera and connected to it through the Web UI and everything was OK.
  • The only problem was that there was no audio and there was no option in the Web UI to enable the audio.
  • I thought that upgrading the firmware would fix the problem.
  • I went to the website http://www.maygion.com and downloaded firmware3.1_full.rar http://www.maygion.com/downloads/20100908/firmware3.1_full.rar in order to update the firmware.
  • I extracted the RAR file, went into the Web UI and updated the UI using the www.bin file. This went OK and I was able to connect to the camera with the new UI.
  • Then, using the Web UI again, I tried to update the app using app.bin. It looked OK and UI said it is rebooting.
  • After the reboot I could not connect to the UI again! Even after searching the IP Address using the IPCamTool,exe, there was no way to connect to it (I tried to connect it directly to the router with a cable).
  • I thought that the firmware was corrupted, so I followed the instructions in http://www.maygion.com/upgrade.html
  • I was able to connect to the FTP (192.168.1.111), but I could not make the IPCamRepair.exe connect to the IP Camera.
  • Although the IPCamRepair could not connect to the IP Camera, I cleared the content of the folders /tmp/eye/app and /tmp/eye/www as instructed and copied the files from the app.rar and www.rar using FTP.
  • After reboot I still cannot connect to the IP Camera using the UI. I can connect only using FTP. So I cannot use the camera :(
What should I do?

Thank you!

August 25, 2011, 04:01:20 PM
Have you tried this??

I got the right firmware from the guy from maygion. See attached files: upload them with ftp, default port for webpage is 81, so connect to http://IP:81 eg. http://192.168.1.118:81

Or just look at this thread http://www.openipcam.com/forum/index.php/topic,168.15.html
« Last Edit: August 25, 2011, 04:05:45 PM by jwp123 »

September 05, 2011, 10:55:23 AM
Yes, I tried it but it did not help.

Does anyone have the original firmware of this IP Camera or maybe knows how to solve this problem?

September 08, 2011, 08:23:19 AM
Maybe try connecting via cable? I think I had some heartattack moment like that also :)
Anyways here is the link to (I believe the original firmware):
http://www.easy-share.com/1918027343/cambackup.zip
The file on firmware files inside the camera was newer, than the 3.1 firmware, so I guess it is newer that 3.1. Also the CS file is much much bigger.
Hop this helps!
BTW: do you have sound from the camera? I can just hear some noise...

September 22, 2011, 04:52:32 AM
I have the same problem here  :-[

I hope using the files of Kokesh it works.Will give it a try today.


Thanks you

September 22, 2011, 12:24:28 PM
Ok, y fixed it with the files attachedd in the other post via FTP server.

September 24, 2011, 08:18:53 PM
hello i lost the ldr file could you resend the file and the firmware thanks

September 29, 2011, 02:08:35 PM
http://www.maygion.com/downloads/20110927/ipcam_mips.htm


Everything is here now since the last update of the page Maygion.

You shoud reset the device, dont use de ipcamfix, just use the ftp program at 192.168.1.111 chanel 21 and use the mips firmware.Dont forget to use the correct user and password that is in the page, its not admin admin.

If you can acces via FTP you can fix the problem, i believe.

October 01, 2011, 07:06:59 PM
Thanks menesto
i try this but the always have the same ip 192.168.1.111 i dont know how to reset the cam i try to push buttom 30 seg but the cam dont do nothing.

thanks a lot

November 01, 2011, 06:41:09 AM
Hi all.

Had an issue with regards to an issue of an IP-Camera that just won't start.  Even if the files in /tmp/eye/ are returned with original files.  I was dumb enough to delete the whole /tmp/eye directory.

WARNING: Do not delete folders or any other files other than those in /tmp/eye/app or /tmp/eye/www

When the /tmp/eye directory is removed instead of just the files in /tmp/eye/app or /tmp/eye/www, this creates an issue where script file (/tmp/eye/init.sh) will not have execution rights.  There is also a hidden file called "ldr".  Luckily the IP-Camera FTP seems to give files without an extension execution rights.

To resolve the issue, follow the following steps:

  • Download the ldr file from https://rapidshare.com/files/2539309861/ldr
  • Download the /tmp/eye/init.sh file via FTP from your IP-Camera
  • Delete the /tmp/eye/init.sh file from your IP-Camera
  • Rename the copy on local PC from init.sh to init
  • FTP the init file back to /tmp/eye/ on your IP-Camera
  • On your IP-Camera rename /tmp/eye/init to /tmp/eye/init.sh
  • Copy the ldr file from your local PC to /tmp/eye/ on your IP-Camera

Kind regards.... ;D

November 03, 2011, 05:37:54 PM
Hi all

can anyone please help with the ftp connection? I'm stuck with FW 11.14.1.34 and cannot upgrade neither with IP Camera Tool nor with webUI. The other utilities don't even see the camera (talking about Master, IPCamTool, IPCamRepair).

When I scan ports the camera has port 21 open for ftp. That's OK.
When I try to connect using filezilla with suggested username: MayGion, passw: maygion.com I get the classic "connected, waiting for welcome message" and then "unable to connect".
The "connected ..." message is kind of weird because I get it even with an IP address I don't have in my network.

With my limited knowledge of rocket science I've run out of ideas. Can anyone help? Thanks a lot.

  • No avatar
  • *****
November 04, 2011, 06:51:47 AM
Can you take a photo of the board inside the camera so we can confirm what it is?

November 16, 2011, 03:03:01 AM

  • No avatar
  • ****
November 16, 2011, 07:44:47 AM
from what I see, this is not a maygion but a standard FOSCAM CLONE.

What is the problem with your firmware, why do you want to update?

Without knowing the manufacturer, a fw update with random files could be the last thing you do with your cam...

November 17, 2011, 11:38:35 AM
i didnt know there was more than one manufacturer of the same camera ... I bought it on dealextreme and neither the box nor the manual says who the manufacturer is ... strange

i'd like to run the UI on Mac/Safari and iPhone ... and connect the camera to Security Spy application (also on Mac)