News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Author Topic: Finding Ground pin on my camera board for UART RX & TX  (Read 5741 times)

  • No avatar
  • *
August 20, 2015, 05:14:49 am
Hello,

I have a problem with my camera board.

https://drive.google.com/file/d/0B_ejNf4SSbEYaUcwTE5mSEVpSGM/view

I find the UART TX and RX but no find Ground !!

How i can find it ?

Thx

  • No avatar
  • *****
August 20, 2015, 05:50:58 am
Hi,
usually one of the big bare copper planes (especially the ones with many holes in it) should be gnd.
These boards use 3,3V level, so beware of old USB/serial converters with 5V!
« Last Edit: August 20, 2015, 05:59:42 am by schufti »

  • No avatar
  • *
August 20, 2015, 03:57:54 pm
Thx for reply !

I test it and not work :(

Another idea ?

Thx

  • No avatar
  • *****
August 21, 2015, 02:27:11 am
leave the board in its place and use a circuit tester to find gdn on the board. Connect one side to gnd of the power connector or other known gnd on the base board and test several blank parts on the daughter board.
Or just look at the connector on base board an try to find the "thick" connectioons, most likely going to two points in a line. Some of these will be +3.3V others gnd. Like here. The ones in the middle are gnd, the ones to the rigth 3.3V.
And maybe you just have to swap Rx/Tx...
« Last Edit: August 21, 2015, 02:45:53 am by schufti »

  • No avatar
  • *
August 23, 2015, 10:12:32 am
Thx for your help !

When a connect i have this (view screenshot in attachment)

It's crypted ?

Thx !!
« Last Edit: August 23, 2015, 10:16:20 am by maxou »

  • No avatar
  • *
August 23, 2015, 03:15:09 pm
Ok it's good my problem is the speed port for me it's 57600.

I have U-Boot 1.1.3 and i don't have ESC command for debug !

Output :

Code: [Select]
U-Boot 1.1.3 (Oct 31 2012 - 23:46:19)

Board: Ralink APSoC DRAM:  32 MB
relocate_code Pointer at: 81fb4000
sysctl:40200300
spi_wait_nsec: 42
spi device id: ef 40 17 0 0 (40170000)
find flash: W25Q64BV
raspi_read: from:30000 len:1000
.raspi_read: from:30000 len:1000
.============================================
Ralink UBoot Version: 3.5.3.0
--------------------------------------------
ASIC 5350_MP (Port5<->None)
DRAM_CONF_FROM: Boot-Strapping
DRAM_TYPE: SDRAM
DRAM_SIZE: 256 Mbits
DRAM_WIDTH: 16 bits
DRAM_TOTAL_WIDTH: 16 bits
TOTAL_MEMORY_SIZE: 32 MBytes
Flash component: SPI Flash
Date:Oct 31 2012  Time:23:46:19
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:128, ways:4, linesz:32 ,total:16384

 ##### The CPU freq = 360 MHZ ####
 estimate memory size =32 Mbytes

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.
 0
   
3: System Boot system code via Flash.
## Booting image at bc050000 ...

It's possible to flash it with option 2 - Load system code then write to flash via TFTP or change bootloader ?

Thx
« Last Edit: August 23, 2015, 04:11:23 pm by maxou »

  • No avatar
  • *****
August 24, 2015, 02:56:41 am
sorry but I'm no expert for these cameras. I'm only familiar with the 1st gen "foscam" clones.

Maybe try option 1 first?

rgds,
schufti

  • No avatar
  • *
August 24, 2015, 03:12:09 am
I try this firmware

http://www.openipcam.com/forum/index.php?topic=473.0

linux.zip and romfs.img not work :(

  • No avatar
  • *****
August 24, 2015, 07:18:54 am
you can't just pick some fw you like and flash it ?!?!?

a) it has to be for the correct paltform (cpu) and
b) for (mostly) similar hardware.

your cpu is ralink rt5350 (rare piece)
your hw is ???? (could be newer megapixel or older magion, but still highly incompatible with most fw on this board)

  • No avatar
  • *
August 25, 2015, 02:46:11 pm
Arghhhh !!

I send a bad U-boot firmware :'(.

Now i don't have data on UART.

It's possible to recover it ?

Thx

  • No avatar
  • *****
August 26, 2015, 04:40:45 am
not with a budget related to the value of the cam....