Open IP Camera Forum

End User => Help => Topic started by: jazzbassNick on June 29, 2014, 10:11:33 am

Title: FI8910 Bricked [SOLVED]
Post by: jazzbassNick on June 29, 2014, 10:11:33 am
Greets all,

I'm using an older USB>DB9 cable and pretty I'm connecting up the right pins, on an actual Foscam 8910.
The bootloader seems to be running - I get a pretty good stream of characters, then a pause, then more characters, but it's all garbled and sending the ASCII ESC key doesn't seem to make a difference. I've tried different baud rates and flow control settings in ClearTerminal to no avail.


Thoughts or suggestions?
Thanks - lots of awesome stuff here. Originally I was just going to see if I could unbrick this cam, but I may have to play with some options.
Title: Re: Garbled characters via ClearTerminal - FI8910
Post by: jazzbassNick on June 29, 2014, 01:18:29 pm
Well, finally getting able to read it. Just disconnected and reconnected the wires and it seems to have done the trick.

Problem now is for the life of me I can't get ESC (or 'B') to get to the bootloader.
The boot process ends with a 'Kernel panic: VFS: Unable to mount root fs on 1f:00'

I've tested the cable (connecting the TX and RD and seeing the echo) so I know the connections are good.

Thanks in advance for any advice.
Title: Re: FI8910 Bricked [SOLVED]
Post by: jazzbassNick on July 03, 2014, 01:59:03 am
Holy crap - I got it working. Documenting here for posterity's sake ;)

Cause: Cam owner attempted firmware update via wifi.

Resolutions:
1) Garbled text: Pretty well documented, but suspect it was a loose gnd connection intially.
2) Unable to send ESC to exit to bootloader: My Radio Shack 26-183 (pretty old) USB-DB9 wasn't handling the 3.3v logic. As soon as I used a CP2102 breakout I was able to send the ESC key. I used ClearTerminal, set my F1 hotkey as hex /1B.

3) Unable to unpack Foscam's FW lr_cmos_11_37_2_59 of 5/15/14 using win_fostarn: I was getting a "File size (1742796) doesn't match the reported header sizes (1742788). File may be corrupt." error. I used cygwin and ran Foscam_pkmgr.sh and it unpacked it perfectly. Note: The romfs.img is labeled as rootfs.img. I used "romfs" in my fx command when uploading. I also changed the .bin of linux.bin to .zip and it uploaded without issue.

The cam is back from the dead! I'm attaching the zip of the segregated rootfs.img and linux.zip. This is the current firmware for the FI8910W as of this posting.
Title: Re: FI8910 Bricked [SOLVED]
Post by: youdgin on July 03, 2014, 08:32:10 am
Congrats, well done. Question : Why did you use F1 hotkey as hex/ 1B for ESC signal? The physical key didn't worked?
Title: Re: FI8910 Bricked [SOLVED]
Post by: jazzbassNick on July 03, 2014, 09:04:20 am
Right - when I was having challenges using the first cable, I thought it might have been it not accepting the keyboard ESC. The original write-up I found talked about using the Tools>Send ASCII/Hex... to send the ESC, but I found it easier just to assign the hot key.
Title: Re: FI8910 Bricked [SOLVED]
Post by: TheUberOverLord on July 05, 2014, 10:37:39 am
Please note. For others.

I have the serial interface recovery methods which include both instructions and images of the PCB IP Camera boards for the serial interface connection and images of the step by step process required to attempt to recover ALL Foscam IP Camera models. Both MJPEG and H.264 Foscam IP Camera models.

So if anyone wants to avoid guessing about this or that and/or unpacking/packing firmware, in order to attempt to bring their Foscam IP Camera back to life. Please simply post in the Foscam.us Forum include your Foscam IP Camera model and I will send your the Instructions and files via PM ("Private Message") there:

http://foscam.us/forum/technical-support-f3.html (http://foscam.us/forum/technical-support-f3.html)

Note: If your camera is a very old Foscam MJPEG based IP Camera. Please look at the label on your camera for a "VNT" or "FR" followed by letters and numbers ("The IP Cameras wireless MAC Address") and post if it says "VNT" or "FR" as well in your post.

The firmware files for the recovery methods are NOT the current firmware versions. But by using them, it may allow you to successfully boot your camera and then install the current firmware version(s) for your camera. Using the normal firmware upgrade methods.

Using the instructions and files is at your own risks. But, they are the same files and instructions that authorized Foscam Resellers worldwide use, when trying to bring ANY Foscam IP Camera models, back to life.

Don