Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: model easyN fs-613b-m166 (b613m136xa pcb)  (Read 24278 times)

  • No avatar
  • *
June 08, 2014, 09:09:15 pm
I was a little preoccupied when I tried to change the firmware on it.. I was trying to fix the color, it was extremely awful.    I will try to post a picture of the board.. it doesn't have the typical j2 pin locations.. :/      any help extremely appreciated..     

*edit, I removed links to personal server, only the google link below is still valid
« Last Edit: June 12, 2014, 04:43:44 pm by ayagle »

  • No avatar
  • *****
June 10, 2014, 02:13:55 am
instead of uploading the same side of the board 3 times (only the last being usefull) to a crappy site, you should have downloaded yourself the datasheet from the download area and look where the pins for the uart are routed to ...

  • No avatar
  • *
June 10, 2014, 11:11:57 am
I do appreciate the feedback, I added a picture of the other side of the j2 location, there is something there but completely different than other boards ive seen pictures of since I started this whole thing.
Could you tell me what it is I am looking for in the downloads section?.. I had'nt seen any info on this board at all.. 

also.. what was crappy about the server?.. did it take a while to load?..     it's my personal server, I figured it was easier than starting a hosting account for a few pics...   

Again, Thanks

  • No avatar
  • *
June 10, 2014, 02:41:24 pm
I just wanted to add some more details to see if anyone could help..  also, would it be ok, (if anyone could answer) could I post this in the firmware section as well?.. or could it be moved?..

The camera will boot up and with it connected to my laptop to attempt to use wireshark the ethernet data light will blink, the infra-red lights will light up and the green light will come on, after about two minutes it reboots.. I tried to flash it with an older version of what was on it, I think it was a 8908 firmware, although I think this board is completely redesigned and using different chips than earlier versions..  I think the bin I flashed was lr_cmos_4_11_2_15.bin or perhaps a different version..  does anyone know, *if* the chip for the ethernet is being initialized, what ip it might give itself with out a dhcp server available?..         Thanks again..

  • No avatar
  • *****
June 11, 2014, 02:50:11 am
arghhh, what do you expect someone to recognize from this pictures ....
On the one picture no ic identifiers can be seen (ok, I know it is a nuc745)
on the second picture all detail that can bee seen is exactly .... naught. usually the wifi board can be removed to get a better view ...  and yes, the loading is awfully slow and not reliable as it never finishes on first attempt.

I was suggesting to download the datasheet for the uC, look what are the pins for uart0 and trace them on the pcb.  (hint: the two traces that end up in vias in the empty silk screen rectangle). My guess: the J2 no longer is "through hole" but only single sided solder points to make it harder for would-be hackers.

The standard IP set from factory (usually something from 192.168.x.x) should be printed on the label on the bottom or mentioned in the manual.
« Last Edit: June 11, 2014, 02:57:11 am by schufti »

  • No avatar
  • *
June 11, 2014, 03:45:08 am
hmm.. sorry about that..  If you can or would like to help, perhaps you can tell me what it is you need to see, or know about the board. I'm not sure what your saying will help me in the d/l section,.. look at the schematics of the older boards to see what the jumpers lead to and do the same with mine?...    as for the server.. I can probably find someplace to put pictures.... It would stand to reason that the connection wouldn't be that great through my residential isp service from overseas. (if that's where you are)

again.. thanks for the input..   and any help is always appreciated..    ;D

  • No avatar
  • *
June 11, 2014, 04:45:44 am
I took some more pictures, but I'm not really sure they will do any good.. I think I understand what your saying about tracing the pinout..   but, anyways..

Google photo's

« Last Edit: June 12, 2014, 04:44:12 pm by ayagle »

  • No avatar
  • *****
June 11, 2014, 07:01:58 am
i did mean you should download this document
and look which pins are for the uart (10,11)
then look at the uC and its surrounding (1.jpg) an see where the traces starting at these pins are leading to (a ->b). As b ends at 2 vias (through connectors) one wants to see where this is going so turns over the pcb ...  and voila, on the other side (2.jpg) one sees the familiar 4 solderpoints where these two lines most likely are leading to. Which makes one think they just didn't make them through hole on the new design.
Another detail would be that exactly at the opposite side of the pcb there ist still the rectagle named J2. All names of parts are close to their silkscreening = white rectangles, so since the connector of the wifiboard has no rectacngle, J2 shouldn't be its name.

So the only thing left is to determine Pin1 of J2, maybe assemble R40 and then follow the other thread here:,736.0.html

  • No avatar
  • *
June 12, 2014, 04:48:56 pm
Ok..  that makes sense, I have gotten the the flashing part figured out and I've learned a bit about this stuff, but I am unable to find the correct firmware.. If I'm able to fix the rx pad on the pcb I'll keep trying..   In the end I think I should have payed more and gotten the real thing..  if anyone asks I will definitely not recommend easyn.. no support and in the attempt to be different they screwed up any ability to even use their product..   between no support and an unfixable product it just makes it a waste of a money..       GL to anyone else messing with this model..    :D
« Last Edit: June 14, 2014, 02:25:10 pm by ayagle »

  • No avatar
  • *
June 16, 2014, 04:40:54 am
Could anyone help me with this?..   I took the rest of the camera apart, the cam board has a v366 chip and is labeled ov7740..      with all of the firmwares I've tried the camera doesn't load, is this a different chip than most cams I hope?.. I'd would love to be done with this little project without wasting $40..   


  • No avatar
  • *****
June 18, 2014, 11:02:49 am
How do you know the camera doesnt load? You allready connected via serial?

  • No avatar
  • *
June 18, 2014, 03:02:45 pm
Hey schufti, how have you been?.    ;D
 Yes, I have put just about every firmware I can find on it.  on everyone of them, during boot, the only usb  device that gets recognised or initialised is the audio.  at least on the ones that finish booting and don't end with a kernel panic.. :/

  • No avatar
  • *****
June 20, 2014, 02:45:49 pm
AS you allready have contact to easyn they should at least be able to send you the Firmware if it is really an easyn camera and no clone. The other Option would be Tod buy another one and extract the Firmware ( not that easy either). In General it should only be necessary to change the Linux AS this bringe the driver. If it cant find the rootfs you flashed a Linux kernel for the 'other' Size flash. If your cam is 4M and one of the 2M kernels would detect the cam, it would be easy to flash the rootfs to the correct address.

  • No avatar
  • *
June 20, 2014, 03:10:27 pm
Hey again shufti
     That does give me something to go on at least.. I am having issues with the rx terminal on the pcb but I am able to use it for a bit until it gets shifted then I have to resolder. (Currently I am soldering to the underside directly to the trace :/ )  Hopefully I will be able to find a decent combo before I loose the ability completely..   

as for easyn.. they claim they can't help..   I read in another post that they feel that the firmware is their proprietary property and won't release it..  so..  idk..    I'll keep trying.. 

  • No avatar
  • *
June 20, 2014, 04:41:38 pm
the more I think about it, I am thinking that the camera on the board isn't even seen, let alone finding a driver..   it seemed like I had two devices that were seen when I started with all this.. but now I get

Code: [Select]
Sash command shell (version 1.1.1)
/> no support
new USB device :80fb4004-fed740
hub.c: new USB device 2, assigned address 2
p1[7]:1,j 3,config->bNumInterfaces:4
usbaudio: device 2 audiocontrol interface 2 has 1 input and 0 output AudioStreaming interfaces
usbaudio: valid input sample rate 48000
usbaudio: device 2 interface 3 altsetting 1: format 0x00000010 sratelo 48000 sratehi 48000 attributes 0x01
usbaudio: registered dsp 14,35
usbaudio: registered mixer 14,32
usb_audio_parsecontrol: usb_audio_state at 00ff3c60
sw version is
aw version is

nevermind, on second thought the second usb device I was seeing previously was the wifi card..  I hadn't noticed I left it unplugged, the whole thing is in pieces, with a delicate serial rx :/
« Last Edit: June 20, 2014, 07:52:32 pm by ayagle »