Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at

Author Topic: GM8125EL - board stopped working  (Read 11058 times)

  • No avatar
  • *
May 19, 2014, 07:53:19 am
Hi everyone,
   i am new here, but i have been looking through the forum for a week or so now just checking stuff out.

I have been playing with a IP camera i bought, it is a Swann ADS-460 is a re-branded camera, both hardware and software re-branded LiveIPC software, it uses SIP to communicate with a US server then some how connects me to my local network. As swanns software is crap and has hardly any useful features. My mission was to grab the video feed and use it with an opensource video surveillance to use around my home.

I couldn't find much info on the internet about the firmware or software of the device, no URL's seem to work for a video feed, i started learning how the camera actually works. I tried using wire-shark to sniff packets, finding no useful info out of the results. I downloaded a copy of the manufactures firmware update and i extracted the files on a virtual machine linux distro to see if i could find any clues on the video feed, but the firmware update did not have much to tell.
Learning the camera has linux on it, i bought a FT232R breakout board. I connected the board to the usb to serial device using 3.3v, tx, rx, gnd. i connected them to the part i have circled in the picture below.

i proceeded to connect the usb to my laptop and opening up the serial port in an application called realterm(i tried putty but putty was playing up for me and not responding) i was able to get some text on the screen using baud rate 38400. but what i found was the linux os was just doing some sort of bootloop and i couldnt enter any of the options it was showing me before it would loop again. i didnt think to get a screen shot so i cannot show you what the text was, i could see something about uboot in the options and some other stuff.

I then plugged in the power to the camera through the cable supplied and finally it stopped looping and ended on a login. I tried guessing the root password to gain access but could not guess no matter what i tried.

This is as far as i got before i started having some real trouble, the next day i plugged everything back in and the device all a sudden stop working all together, the little light that flashes when linux is booting no longer turns on. the board gets hot in places, in a nearby section to where the power plugs in. In the photos bellow, the smaller circle is the hottest part and from there to the outer circle its warm.

My UART, FT232R device no longer works either, for some reason when i plug the power in to the camera, the 2 lights turn on and stay on and the device gets hot, too hot to touch.

I have unplugged everything off the board except for the power to see if that would change anything but it didnt. i cannot see any burnt connections or anything that looks broken.

i have since learnt that the board is from a company called grainmedia who supply boards for ip cameras. the board is a GM8125EL, i now downloaded datasheets and docs on this but this isnt useful now the board doesnt work.

This is as far as my experience and knowledge goes with this kind of stuff, can anyone here possibly explain what i may have done wrong or how i could possibly get my board working again?

sorry for the story, but i thought knowing the story behind how i broke my device might help, not posting my device is broken with no info. Hope someone can shed some light, this has me disappointed that i may have wrecked my device.

Below i have added a few photos of the board. for some reason images arent alligned nor is full image shown, best way to see is to right click and open image in new tab to view full photo.

serial connections

this is the parts thats getting hot, smaller ring hottest.

  • No avatar
  • *****
May 20, 2014, 08:38:33 am
The parts you circled are switch mode voltage converters/regulators.
If they get hot that could have numerous reasons. E.g. some short circuit on the board, wrong AC adapter, defective semiconductor ...  maybe J21/J22 mixed up, seem to the same but who knows?

  • No avatar
  • *
October 22, 2014, 06:32:18 am
This is cool will bookmark it and check the site progress