Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: Telnet password and username for IPC  (Read 117441 times)

  • No avatar
  • *
April 15, 2014, 11:55:56 am
I purchased a couple of these cameras: There are several of these on the internet and while they look to be the same, mine has an "Amovision" label on it, so I'm not quite sure whether all these are clones or they're all the same but with a different brand on it.

I wanted to fool around and see what's inside the firmware. See if I can get a few things to work like emailing, motion detection and stuff. I guess it should be simple since the firmware comes with those features - they simply aren't working at the moment.

The seller refused to provide the telnet password and username. I've tried a lot of combinations without success. I do have a serial converter but I wanted to avoid disassembling the device.

The web UI has an option for upgrading a new firmware but I haven't been able to find any.

Any clues on where to start?

Thanks a lot!

  • No avatar
  • *
April 22, 2014, 08:56:33 pm
I have the same (?) camera, at least by the outside looks, bought here:
My camera is labelled as: Vanxse Model V-B811, but I've seen many variants, as far a Vendor and Model numbers go, on different reseller sites.
I lost access to web interface on port 80, nmap scan shows only ports: 21 (ftp), 23 (telnet) and 5050 (multimedia conference control tool) open on the camera. Can't access with Telnet, wrong username and/or password, but I was able to pull some files with FTP. There were the two directories listed, "/conf" and "/custom" (can send via PM), which do not mean a whole lot to me. Poked around some of the ".html" files, but did not find anything of use. Seems like most of the configuration is saved in ".json" files.
The reseller did not provide any files or directions upon request (get what you pay for...)
Camera goes apart fairly easily, just carefully unscrew the body (threads are under the ring), paying attention not to mess up the wiring inside.
This is what is printed on the board: Hi3518_OV9712_v2.2.3_SQ38, which tells me it has a Hi3518 chip with OV9712 CMOS, version 2.2.3 (?) and whatever SQ38 is...
Will post some pictures of the board later on today...
Hope to get some more good info sharing going on here.
« Last Edit: April 24, 2014, 12:15:31 am by kozmo2k »

  • No avatar
  • *
April 22, 2014, 08:59:27 pm
Pictures of the board

  • No avatar
  • *
May 01, 2014, 04:25:19 pm
Thanks for providing some nice pictures. I can't recognise any RX or TX pins. Did you get access to the serial console?

Also, if you can send me the files that you downloaded that'd be great. Mine does not seem to have FTP access enabled by default.

Code: [Select]
23/tcp  open  telnet
80/tcp  open  http
88/tcp  open  kerberos-sec
554/tcp open  rtsp
« Last Edit: May 01, 2014, 04:32:52 pm by juanpi »

  • No avatar
  • *
May 11, 2014, 03:01:37 pm
PM sent with links...

  • No avatar
  • *
May 12, 2014, 07:52:16 am
Seems like the files you sent to me are some configuration json files. There is no reference to any telnet settings, though.

Thanks for the PM.

  • No avatar
  • *
May 13, 2014, 08:51:13 am
That is all I was able to pull with FTP.

  • No avatar
  • *
May 18, 2014, 08:35:56 pm
I have a similar one, but the board layout is different. Just by looking at your board, the likely candidates for the serial are either the 2 or 3 pad groupings next to the Hi3518 IC.

If it's the 2 pad pair, you can pull GND from one of the holes for the standoffs.
Mine had a 3pad grouping close to the edge of the board.

I've only made slight progress. (dumped flash, extracted the firmware's fs partitions, and mounted the on a linux box)
I've also been trying to get the telnet password, but so far I've come to the conclusion that the password has to be reset in the firmware and re-flashed onto the camera.  I haven't gotten that far yet.  But I was able to view the /etc/passwd & /etc/passwd- files and here's what they have  (I've tried some rainbowtables with no luck).

Code: [Select]
Code: [Select]
For mine re-flashing  to get telnet looks to be the only option for terminal access.  Because the serial connection stops after the kernel is loaded.  Which makes me think that either the kernel wasn't compile with tty support - or something is missing in the config.

Here's what I get during boot:
Code: [Select]
U-Boot 2010.06 (Jun 26 2013 - 09:59:34)

DRAM:  256 MiB
Check spi flash controller v350... Found
Spi(cs1) ID: 0xEF 0x40 0x17 0x00 0x00 0x00
Spi(cs1): Block:64KB Chip:8MB Name:"W25Q64FV"
MMC:   MMC FLASH INIT: No card on slot!
envcrc 0xcbb66e64
ENV_SIZE = 0xfffc
In:    serial
Out:   serial
Err:   serial
Press Ctrl+C to stop autoboot
8192 KiB hi_sfc at 0:0 is now current device

### boot load complete: 2382412 bytes loaded to 0x82000000
### SAVE TO 80008000 !
## Booting kernel from Legacy Image at 82000000 ...
   Image Name:   linux
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2382348 Bytes = 2.3 MiB
   Load Address: 80008000
   Entry Point:  80008000

   Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

« Last Edit: May 18, 2014, 08:37:29 pm by sudoninjas »

  • No avatar
  • *
May 18, 2014, 09:31:32 pm
I took a couple pictures and labeled the serial connection on mine.  Turns out it's much more different than I first thought.  But I hope some of this info at least adds to the pool of knowledge on these cameras.

  • No avatar
  • *
May 31, 2014, 04:09:57 pm
sudoninjas: Hi, I have the same board in my cam. Im new in cams, but what I need, is to now the path of the stream, because I want connect this cam to Synology SS. Can you help my?

  • No avatar
  • *
September 25, 2014, 07:15:54 am
Hi ludom!

You can set them up as Generiv ONVIF Camera! Works fine for me! The port should be 1018 by default!
Also you could ssh to your NAS and create a file for this cam...

  • No avatar
  • *
April 09, 2015, 06:57:48 pm

If you still need the password for that hash here it is: xmhdipc

  • ***
August 01, 2015, 02:38:30 pm