Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at

Author Topic: Ading programs to romfs  (Read 12273 times)

June 24, 2012, 02:51:13 am
Hello! I try to compile 2.6 kernel for nuc745 and it fully working, but here is no sshd server... Tried to add sshd option into "Customize Application/Library Settings", but in romfs dir i don't see any sshd binary. How to add it into image? Thank you!

  • No avatar
  • *****
June 29, 2012, 01:44:17 am
You need to build a romfs to add software.

genromfs will build a romfs from a folder.
You can copy the binaries to that  folder on your computer and build the romfs.
Suggest also flthdr -z <BINARYNAME>  to compress your binary, as space is an issue.

You can either download existing romfs's, mount then copy to elsewhere to build folder structure, or you'll need to create the default folder structures.  I think I have a script in this forums which does it for you if you look for it
(found it -,115.0.html (only for /dev though) )

If you do the download existing route, then

mkdir /mnt/myromfs
mount -o loop -t romfs  ROMFSFILENAME   /mnt/myromfs

and copy to elsewhere.

Then add in your binaries.

Genromfs point to new location, and you have a new romfs to use.
« Last Edit: June 29, 2012, 01:46:36 am by admin »

July 02, 2012, 06:09:40 am
I used 2.6 version with built-in cpio image included into kernel(generated by uclinux's make) - it working fine, but telnetd binary from your file archive or compiled ser2net doesn't work - ser2net have no open ports and said nothing with any config(maybe my mistake - I changed two fork() to vfork() - just one way to right compilation), but telnetd said "no such applet".

July 02, 2012, 10:40:21 am
problem half-solved! I used uclinux's busybox and it doesn't work for me, but BSP contains another busybox sources and just now it compiled perfectly, except some functionality - port is opened but there is no sense if I try to connect - kernel doesn't have PTY support. Here is manual for others who want walk this way:

Thank you for help! Post still opened, because I haven't working telnetd or sshd or ... yet

  • No avatar
  • *****
July 05, 2012, 09:55:14 am
Have you compiled in ethernet support (or wifi)?
Have you setup the GPIO ports appropriately

Have you assigned a mac address to the ethernet card?

Is wifi or ethernet actually up?
Did you push relevant bits to the GPIO's for network?  eg pass 0x55555 to GPIO at 0xFFF83020? and preset the MAC etc (see the ethernet driver for more boring details)

Can you get an ip address?

July 11, 2012, 01:48:21 pm
Yes, I added full network support
What do you mean say about GPIO? Default setting in BSP have three UART in .config, all of this turned on now
Yes, mac, ip in bootloader and after linux loading I set all of it
Ethernet is up. 100MB Full duplex
Hmmm... I thought that if network is up, not need to do anything else
Yes, ifconfig works normally and nmap said that host is up with 23 listen port.