News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Author Topic: J2 on Foscam FI8918W  (Read 10902 times)

November 06, 2011, 06:32:45 pm
I'm trying to connect a serial port to my camera, and from the outside edge of the printed circuit board, I *think* this is the J2 pin configuration:

1 - 3.3V DC
2 - TX or RX
3 - GROUND
4 - TX or RX

I used a meter to verify #1 was the voltage, and #3 had continuity with the screw holding the metal standoff for the Via VT6656 wireless card, so I interpreted that as ground.  But I cannot get any data out of pins 2 and 4, no matter which way I connect the RXD line.

FYI, I'm using a Prolific PL-2303 USB serial converter connected to a Windows system running the Putty terminal program.  I've used this converter for Arduino projects in the past, and it's generally been VERY reliable for downloading binaries.  I set the COM3 port for 115200 baud rate, 8 bits, no parity.  Still no output. :(

Any suggestions?

  • No avatar
  • *****
November 07, 2011, 01:18:45 am
if you risk just one glimpse into the wiki, you'll find the section about serial console with the correct pinout...

November 08, 2011, 02:32:05 pm
I respectfully disagree.  This page in the wiki is blank/empty. :(

Also, this page in the Wiki is a generic specification, with no indication it specifically applies to the FI8918W. 

I have two more cameras on order.  As soon as they arrive, I will gather pictures specific to the FI8918W.

« Last Edit: November 08, 2011, 02:35:42 pm by PinkFreud »

  • No avatar
  • *****
November 08, 2011, 03:29:20 pm
indeed I didn't mention anything about "motherboard components" or else...

I definitely referenced the section about serial console what's the exact name of the wiki section....

instead of nitpicking you could have tried the pinout from the wiki and made a hit on the first run....

maybe there is nothing special on FI8918W? HW wise its basically the same as every other "clone" ip-cam. Only the relay and io connector are missing (the traces exist) as the i/o is used to switch the leds.