Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: DB power bricked  (Read 14609 times)

April 25, 2012, 03:44:40 pm
HI there i updated firware as wireless didnt work from new supplier wouldnt swap , I have a db power

this one to be specific

inside it looks like this,
the wireless board is soldered in place

there is  a lot more info on the camera  here its in italian but can be translated.

Any one have any idea what firmware can be used to get camera back? and what procedure?
thanks a lot in advance!!

  • No avatar
  • *****
April 26, 2012, 04:32:09 am
it definitely is a WanScam OEM (as seen on the pcb).

There are two firmwares av. for this manufacturer, for 2MB and 4MB devices.

You have to connect via serial console and make a bootlog to determin.

see here about proceedings

May 01, 2012, 06:38:19 am
thx alot
would this cable work ?
this place is only 2 mins away from me!!


May 01, 2012, 02:00:30 pm
hi there here is bootlog

W90P745 Boot Loader [ Version 1.1 $Revision: 1 $ ] Rebuilt on May 11 2010
Memory Size is 0x1000000 Bytes, Flash Size is 0x400000 Bytes
Board designed by Winbond
Hardware support provided at Winbond
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.
Boot Loader Configuration:

        MAC Address         : 00:A1:10:51:00:13
        IP Address          :
        DHCP Client         : Enabled
        CACHE               : Enabled
        BL buffer base      : 0x00300000
        BL buffer size      : 0x00100000
        Baud Rate           : -1
        USB Interface       : Disabled
        Serial Number       : 0xFFFFFFFF

For help on the available commands type 'h'

Press ESC to enter debug mode .....

Cache enabled!
Processing image 1 ...
Processing image 2 ...
Processing image 3 ...
Processing image 4 ...
Processing image 5 ...
Processing image 6 ...
Processing image 7 ...
Unzip image 7 ...
Executing image 7 ...
Linux version 2.4.20-uc0 (root@maverick-linux) (gcc version 3.0) #978 ËÄ 8ÔÂ 20 01:23:39 CST 2009
Processor: Winbond W90N745 revision 1
Architecture: W90N745
On node 0 totalpages: 4096
zone(0): 0 pages.
zone(1): 4096 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/rom0 rw
Calibrating delay loop... 39.83 BogoMIPS
Memory: 16MB = 16MB total
Memory: 14376KB available (1435K code, 288K data, 40K init)
Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
Inode cache hash table entries: 1024 (order: 1, 8192 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Winbond W90N745 Serial driver version 1.0 (2005-08-15) with no serial options enabled
ttyS00 at 0xfff80000 (irq = 9) is a W90N745
Winbond W90N7451 Serial driver version 1.0 (2005-08-15) with no serial options enabled
ttyS00 at 0xfff80100 (irq = 10) is a W90N7451
I2C Bus Driver has been installed successfully.
Blkmem copyright 1998,1999 D. Jeff Dionne
Blkmem copyright 1998 Kenneth Albanowski
Blkmem 1 disk images:
0: 700000-6FFFFF [VIRTUAL 700000-6FFFFF] (RO)
No supported flash detected!
01 eth0 initial ok!
PPP generic driver version 2.4.2
Linux video capture interface: v1.00
Winbond Audio Driver v1.0 Initialization successfully.
usb.c: registered new driver hub
add a static ohci host controller device
: USB OHCI at membase 0xfff05000, IRQ 15
usb-ohci.c: AMD756 erratum 4 workaround
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver audio
audio.c: v1.0.0:USB Audio Class driver
usb.c: registered new driver serial
usbserial.c: USB Serial Driver core v1.4

 _____     ____    _    ____
|__  /   _|  _ \  / \  / ___|
  / / | | | | | |/ _ \ \___ \
 / /| |_| | |_| / ___ \ ___) |
/____\__, |____/_/   \_\____/
ZD1211B - version
usb.c: registered new driver zd1211b
main_usb.c: VIA Networking Wireless LAN USB Driver 1.13
usb.c: registered new driver vntwusb
usb.c: registered new driver rt73
dvm usb cam driver by Maverick Gao in 2006-8-12
usb.c: registered new driver dvm
dvm usb cam driver 0.1 for sonix288 by Maverick Gao in 2009-4-20
usb.c: registered new driver dvm usb cam driver for sonix288
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 1024 bind 2048)
Blkmem: bad access: block=0, count=2 (pos=400, len=0)
end_request: I/O error, dev 1f:00 (Blkmem), sector 0
romfs: unable to read superblock
Kernel panic: VFS: Unable to mount root fs on 1f:00

can you point me in direction of firmware to use?  thanks so much fr your help!!

  • No avatar
  • *****
May 01, 2012, 03:38:02 pm
so it is a 4MB device. you can try the fw from this thread,218.0.html  and follow the usual flashing instructions (foscam etc) that are for 4MB devices.

May 01, 2012, 04:40:04 pm
this 1  ???
thanks alot

p.s have you a link to the 4b recovery you talk of ?
and a link of how to get rom and other files from a .bin

once again thank you
« Last Edit: May 01, 2012, 04:45:57 pm by madmanc »

  • No avatar
  • *****
May 03, 2012, 05:41:54 pm
for splitting search for fostar
flashing instructions are

Code: [Select]
From the bootloader prompt
del 7
del 6

FX 7 linux 0x7f020000 0x00008000 -acxz
Then initiate an XMODEM SEND of
After the flash has stored the image, proceed to the next.

FX 6 romfs 0x7f0E0000 0x7f0E0000 -a
SEND romfs.bin
Wait for flash to finish storing.

FX 8 webui 0x7f180000 0x7f180000 -a -nofooter
SEND webui.bin
Wait for flash to finish storing.

May 03, 2012, 06:24:23 pm
hi thanks for that mate , i have tried all sorts of firmware all result in ic2 errors and the camera in constant reboot , i also tried plugging ethernet in at the point in one of your threads, one thing i havnt done is uploaded a web ui , would no web ui cause constant reboots? also i have fostar , i open it and its a blank black terminal i havnt a clue what commands to input and ive searched all over for instructions with no success , i also emailed db power 5-6 times asking for the firmware the dont reply (no more db power purchases for me )
thanks vfery much frien you have been a big help!

  • No avatar
  • *****
May 04, 2012, 02:26:12 am
no, missing webui shouldn't be cause for i2c errors and reboot.
if it is a i2c error with "myreboot" at the end it is most likely a incompatible cmos sensor chip...
you could try to flash the 2MB ali2/wanscam firmware (but be aware of different flash address for webui)

May 06, 2012, 10:30:41 pm
well ive spent 3 days trying to split the bin files to and romfs.img  and havnt got anywhere ive read stuff 1000 times with no joy..........

can any one help me out and split the 2 wanscam firmwares ( 2 and 4 mb fw) and also the heden fw into  rom and linux files for me?? a free beer for anny help is offered!!!

thanks to any one who can help!!!!!!!!!!!!!! ;D

  • No avatar
  • *****
May 07, 2012, 04:51:15 am
did you use this version

May 07, 2012, 04:58:00 am
Hi yes i downloaded that tool , but i havnt got a CLUE what to do with it , i have searched the net for 4 days trying to find out how to use it but to no avail im simply lost with the tool regretably.


  • No avatar
  • *****
May 07, 2012, 05:00:49 am
this tool is a command line tool, no fancy GUI.
You have to open CMD Window, then start the program and it will show you how to use...

May 07, 2012, 07:29:18 am
thanks for the tip, heres what ive tried to do but with no success

placed win_fostarn.exe on the c:\  i also made a file named fostar (its empty) on c:\

in command a cd c:\   then i type   win_fostarn.exe 

there is now no promt and i am typing fostar -u lr_cmos_0_23_2_21.bin

then it gives all the help lines again and nothing else i really am lost here .  thanks for your help i really do apreciate it

  • No avatar
  • *****
May 08, 2012, 02:37:27 am
if your at "C:\>" and the win_fostarn.exe plus firmware file are in the same directory then
type win_fostarn -u lr_cmos_0_23_2_21.bin and voila the and romfs.bin should appear.

there are 2 ambiguities:
 1. the program shouldn't stop after the help text, so you think it waits for your input
 2. the help should use the correct name of the started program
 (or the program should be renamed to fostar, but the you wouldn't know its the new one)

solved in attached version
« Last Edit: May 08, 2012, 03:38:55 am by schufti »