Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at

Recent Posts

Pages: 1 [2] 3 4 ... 10
Feature Suggestions / Re: UI for Camera
« Last post by wannaxaxa on November 23, 2018, 10:13:44 pm »
I think full crossplatform functionality as a feature is relativly important. Fancy ajax stuff would make it nice and modern since there isn't much space on a 2MB flash unit for fancy graphics though.

สล็อตออนไลน์ maxbet จีคลับ
General Discussion / Re: How to Purchase a suitable IP Camera
« Last post by wannaxaxa on November 22, 2018, 04:21:59 am »
I'm not French but very versatile material. Plk is new knowledge. To study more

จีคลับ Maxbet
Help / Re: Help enable telnet
« Last post by Yamonaru on September 25, 2018, 06:45:05 am »
We want to be part of giving advice and information that is beneficial to those who are looking for.
Hacking & Modding / Re: Bricked hi3516c - tried everything
« Last post by Yamonaru on September 25, 2018, 06:41:49 am »
We think this is a great channel for providing useful information.
Help / Re: Help enable telnet
« Last post by EvylRat on August 15, 2018, 08:02:49 am »
What success did you achieve with this camera? I have two myself and hate the firmware on them.
Hacking & Modding / Bricked hi3516c - tried everything
« Last post by russellhq on August 11, 2018, 04:18:27 am »
I bought a hi3516cv300 ip camera from aliexpress, this one:

Plan was to modify it for astronomy use and it was going well until I bricked it  :-[

I first tried to save a copy of the existing firmware using one of those black edition CH341a programmers (again from aliexpress) but I could not get this to work. I tried the CH341a Programmer tool, it would connect to the black edition but would not read the chip (it just returned 16MB of FF ). I tried AsProgrammer and it has similar issues. I also tried flashrom and it wouldn't even connect to the black edition. I carried out the 3.3v mod on the black edition but this didn't work either. So i gave up with this tool.

I next soldered pins to the TX, RX & GND on the camera and was able to get a serial connection running and get into u-boot (the camera did not present a console when boot was complete).

Once in u-boot, I made a copy of the firmware and copied it out with tftp. I did a number of tests to verify the copy worked e.g. using binwalk and also copying the romfs partition and mounting it on my linux machine (all worked ok).

So next was to flash the kernel and rootfs from the SDK, this seemed to go OK, i could still get into u-boot. I changed the boot arguments and was able to load the kernel, but this would crash out at loading the rootfs and I got a kernel panic message. I then decided to go all the way and also load the u-boot image from the sdk as well. This also worked and I got into the sdk u-boot and could load the kernel. This time I got a root access and a terminal connection but rootfs still wasn't loading.

So it was at this point where the brick happened. I had rebooted the device and loaded the kernel and was on the console screen when for some reason I pulled the plug on the camera instead of using the reboot command. The serial screen reset and stayed blank  :-[

I tired unplugging it and leaving it for a while. I checked the power supply. I even tried flashing the firmware backup I made. Nothing seemed to work. The serial connection still just gave a blank screen. There was  some data commming through on power up but that was on about 20 characters of blank text (shown by the cursor moving).

My next move is to desolder the flash chip and see if it can be programmed that way but i'm waiting on some tools arriving.

Is there anything I should try in the meantime to get this camera back up and running?
XiaoFang (小方) / Re: Basic info, SDK links
« Last post by RobertBooks on August 09, 2018, 01:33:00 pm »
Help / Which firmware for EDIMAX IC-7110W ?
« Last post by BenGonGon on August 01, 2018, 08:42:26 am »
I have an old Pan-Tilt Camera and new browser cannot drive it.
The constructor don't renew firmware.

It is an Edimax IC-7110W

Which firmaware do I install(

Thank you for your help.
This content is worth reading for those who hope in this fully without worrying about others anymore.
Firmware / Re: Firmware Vstarcam T6836
« Last post by Francois on August 01, 2018, 12:33:32 am »
The entry of details make us feel better when they see the description to follow forever.
Pages: 1 [2] 3 4 ... 10