News:

Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - piecesmel

Pages: [1]
1
Hacking & Modding / Re: Hacking the IPRobot3
« on: February 21, 2014, 04:59:38 pm »
Update
       Working again after loading the Linux & User partitions from a donor Iprobot3 using uboot. Then doing a firmware upgrade with the upgrade tool fixed the SETUP not working in the browser.


2
Hacking & Modding / Re: Hacking the IPRobot3
« on: February 02, 2014, 04:45:24 pm »
But this camera has always had a problem with dropouts even when connected to a wired ethernet connection, it worked well for an hour then drops out and creates continuous events on my zoneminder setup.

Your camera looks to be very unstable not a good time to upgrade !. I would first check the power plug pack ive had capacitors die in mine with in a few weeks of getting it .If your lucky it might work then .


Once thats checked I would try the RS232 first telnet method mentioned earlier in this thread   jtagg method would be a last resort .

Looks as tho you have the newer 2013 model by the look of the firmware your using ( no green connector on the back ?.


3
Hacking & Modding / Re: Hacking the IPRobot3
« on: January 31, 2014, 04:30:02 pm »
I have loaded a bin for linux and other files from a firmware update file mentioned here. http://www.openipcam.com/forum/index.php/topic,386.msg3495.html#msg3495.
Im getting to here in the boot.sh
_______________________________________________
/usr/sbin/telnetd
mke2fs /dev/ram0
mount -t ext2 /dev/ram0 /mnt/mtd/rd
mkdir /mnt/mtd/rd/jpeg
if [ -f /mnt/mtd/html.tgz ]; then
   tar -xzf /mnt/mtd/html.tgz -C /mnt
fi

cd /mnt/
./ipc8126
sleep 5
RETVAL=$?
if [ $RETVAL != 1 ]; then
echo ------- Start uploader --------
/mnt/uploader 0
#/mnt/uploader $?
echo ------- Uploader terminated --------
fi

reboot
______________________________________________
/mnt/mtd/boot.sh: line 51: mke2fs: not found
mount: mounting /dev/ram0 on /mnt/mtd/rd failed: No such file or directory
mkdir: cannot create directory '/mnt/mtd/rd/jpeg': No such file or directory
/mnt/mtd/boot.sh: line 56: tar: not found
/mnt/mtd/boot.sh: line 59: ./ipc8126: not found
______________________________________________
And seem to be missing some files mainly mke2fs , tar , ipc8126, uploader . I added the sleep 5 to allow easy exit from the endless rebooting

Anyone out there check theirs and check what im missing ????

4
Hacking & Modding / Re: Hacking the IPRobot3
« on: January 24, 2014, 06:51:07 am »
I have made progress . I have no booting at all its all gone so the serial port is useless ATM . With nothing to loose I read some documentation about the GM8126 and how it can the load the SPI flash via USB . After checking the pins I was delighted to find the USB had been implemented and was being used for the wireless board .After removing the wireless board and connecting a USB cable to the PC the MP tool found the SPI flash and I can write to it .

I can now watch a boot using the serial port again but need the correct bin files for camera operations. The burn in program allows a "(77) Burn fresh spi flash " but not one big block . ????
Looks as tho it can be done through U-boot .
Would anyone be good enough to post or Email dumps of the SPI flash partitions ???? Mines the old camera with the alarm connector on the back .


/ # cat /proc/mtd
dev:    size   erasesize  name
mtd0: 0067f000 00001000 "Linux Section"
mtd1: 00100000 00001000 "User Section"
mtd2: 0000f000 00001000 "Loader Section"
mtd3: 00050000 00001000 "BurnIn Section"
mtd4: 00020000 00001000 "UBoot Section"
mtd5: 00020000 00001000 "CFG Section"


I hope this help others with the same problem .



5
Firmware / Re: Foscam 9820 CLONE firmware. Help me ID .pk2 file?
« on: January 06, 2014, 04:18:08 am »
Hi,

I wrote an firmware un- and repacker for the PK2 files.

Regards,
leecher

Thanks leecher this might do the trick to bring my Iprobot3 back to life. Just waiting for the converter to turn up .


6
Hacking & Modding / Re: Hacking the IPRobot3
« on: January 04, 2014, 04:29:42 pm »
Telnet, root's password and other camera internals.

To fix this you need a TTL <-> USB (RS232) cable properly connected to the camera (see above for details).

A big thanks to Robo pedrovski & mrc333777 and others for the progress.

I have done a foolish thing and bricked my IPROBOT 3 early version with even ending firmware .Is it possible to reload original firmware using a sd micro card or just copy files from a good copy from a donor camera  using the methods used in this thread .

Many thanks in advance  .


Pages: [1]