News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Recent Posts

Pages: [1] 2 3 ... 10
1
General Discussion / Re: FI9831W - Linux-compatible WebUI?
« Last post by 2018cam on December 13, 2018, 12:04:50 pm »
Hi mbirth,
I'm a newbie of ip cam world, after 2 year and some months my FI9831W as stopped working.

After some search, I've found serial port and I've tried a firmware recovery with u-boot, but with a very bad result.
Now my camera is not booting.
Seems I've overwritten u-boot partition.

Using flashrom sw and Raspberry Pi I can read/write the eeprom but I dont have the image.
Reading your edit I hope You have a backup of image of your camera. :)

I've searched the files section but without success, can you give me eeprom image or a suggestion?

Thanks
2
 
Компаниям и частным лицам, которые планируют обустроить спортивную площадку возле дома, на набережной, в парке или в сквере, наш завод детского игрового и спортивного оборудования предлагает купить уличные тренажеры по выгодной цене.
Мы реализуем сертифицированную продукцию: все уличные спортивные тренажеры, представленные в нашем каталоге, проходят проверку на качество, изготавливаются из оригинальных деталей. В их основе – нержавеющая сталь, которая не боится влаги, плесени, коррозии. У нее высокий запас прочности и продолжительный срок службы. Сверху спортивное оборудование покрыто порошковой краской. Тренажеры для рук оснащены удобными ручками из пластика, который предотвращает скольжение.
Только у нас  железные  уличные тренажеры  купить у  заслуживающего доверия  магазина  SPORTHAPPY. Ссылка на наш сайт завода http://www.sporthappy.com.ua/Trenazheryi_dlya_ulitsyi
3
Help / IP Cam Identification Assistance
« Last post by bofh5 on November 27, 2018, 07:30:26 am »
Hello All
I have bought an IP cam but didn't realise it was locked down to an app that uses chinese servers to access it.
It is this one here http://www.floureon.com/product-g_365.html
I don't think it's a floureon though as it got a firmware update from Yitechnology when i first set it up.
I can access telnet on it using root and no password on port 23
It shows Lobster at the top which i assume is the linux os.
There is no rtsp wo they have crippled it :(
I'm trying to figure out how i can identify if it's a clone of a Yi or something else.
The app it uses is YI IOT
I've tried every bit of software i can find to try and id it but they can't as it's locked down.
Wireshark hasn't been able to help either.
Does anyone know if there is a config file or something that might have more info about the hardware ?
It wasn't expensive so if i brick it i'm not bothered but would like to either flash a replacement firmware or enable rtsp somehow.
Thanks all
Cheers
J
 
4
Feature Suggestions / Re: UI for Camera
« Last post by wannaxaxa on November 23, 2018, 10:13:44 pm »
I think full crossplatform functionality as a feature is relativly important. Fancy ajax stuff would make it nice and modern since there isn't much space on a 2MB flash unit for fancy graphics though.








สล็อตออนไลน์ maxbet จีคลับ
5
General Discussion / Re: How to Purchase a suitable IP Camera
« Last post by wannaxaxa on November 22, 2018, 04:21:59 am »
I'm not French but very versatile material. Plk is new knowledge. To study more





จีคลับ Maxbet
6
Help / Re: Help enable telnet
« Last post by Yamonaru on September 25, 2018, 06:45:05 am »
We want to be part of giving advice and information that is beneficial to those who are looking for.
7
Hacking & Modding / Re: Bricked hi3516c - tried everything
« Last post by Yamonaru on September 25, 2018, 06:41:49 am »
We think this is a great channel for providing useful information.
8
Help / Re: Help enable telnet
« Last post by EvylRat on August 15, 2018, 08:02:49 am »
What success did you achieve with this camera? I have two myself and hate the firmware on them.
9
Hacking & Modding / Bricked hi3516c - tried everything
« Last post by russellhq on August 11, 2018, 04:18:27 am »
I bought a hi3516cv300 ip camera from aliexpress, this one:
https://www.aliexpress.com/item/Intelligent-Analysis-H-265-H-264-IPC-3-0MP-1-2-8-Sony-IMX291-Hi3516C-V300/32850733000.html

Plan was to modify it for astronomy use and it was going well until I bricked it  :-[

I first tried to save a copy of the existing firmware using one of those black edition CH341a programmers (again from aliexpress) but I could not get this to work. I tried the CH341a Programmer tool, it would connect to the black edition but would not read the chip (it just returned 16MB of FF ). I tried AsProgrammer and it has similar issues. I also tried flashrom and it wouldn't even connect to the black edition. I carried out the 3.3v mod on the black edition but this didn't work either. So i gave up with this tool.

I next soldered pins to the TX, RX & GND on the camera and was able to get a serial connection running and get into u-boot (the camera did not present a console when boot was complete).

Once in u-boot, I made a copy of the firmware and copied it out with tftp. I did a number of tests to verify the copy worked e.g. using binwalk and also copying the romfs partition and mounting it on my linux machine (all worked ok).

So next was to flash the kernel and rootfs from the SDK, this seemed to go OK, i could still get into u-boot. I changed the boot arguments and was able to load the kernel, but this would crash out at loading the rootfs and I got a kernel panic message. I then decided to go all the way and also load the u-boot image from the sdk as well. This also worked and I got into the sdk u-boot and could load the kernel. This time I got a root access and a terminal connection but rootfs still wasn't loading.

So it was at this point where the brick happened. I had rebooted the device and loaded the kernel and was on the console screen when for some reason I pulled the plug on the camera instead of using the reboot command. The serial screen reset and stayed blank  :-[

I tired unplugging it and leaving it for a while. I checked the power supply. I even tried flashing the firmware backup I made. Nothing seemed to work. The serial connection still just gave a blank screen. There was  some data commming through on power up but that was on about 20 characters of blank text (shown by the cursor moving).

My next move is to desolder the flash chip and see if it can be programmed that way but i'm waiting on some tools arriving.

Is there anything I should try in the meantime to get this camera back up and running?
10
XiaoFang (小方) / Re: Basic info, SDK links
« Last post by RobertBooks on August 09, 2018, 01:33:00 pm »
Pages: [1] 2 3 ... 10