Open IP Camera Forum

Development => uCLinux => Topic started by: AR84 on November 22, 2017, 07:20:26 am

Title: Fix KRACK ATTACK in ARM Linux
Post by: AR84 on November 22, 2017, 07:20:26 am
Hi guys,

I would like to fix the KRACK Bug in the Linux running on the IP cameras.
In my case the camera is running Linux version 2.6.28

Does anyone know which of the files inside the Linux needs to be modified to solve the KRACK vulnerablility?

Any ideas would be welcome.

Thanks in advance.
Title: Re: Fix KRACK ATTACK in ARM Linux
Post by: admin on November 23, 2017, 11:29:43 pm
wpa_supplicant version 2.4 and above is affected, so replace that.

That said I'm not actually sure that the version on the camera is vulnerable, it might actually be too old.