News:

Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - oic41208

Pages: [1]
1
I followed the instructions, and got kernel compiling, however I cannot make the thing boot. My camera is FI8910W, and when I boot I'm getting nothing on the console:

Code: [Select]
W90P745 Boot Loader [ Version 1.1 $Revision: 1 $ ] Rebuilt on May 11 2010
Memory Size is 0x1000000 Bytes, Flash Size is 0x400000 Bytes
Board designed by Winbond
Hardware support provided at Winbond
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.
Boot Loader Configuration:

MAC Address         : 00:0D:C5:DB:46:96
IP Address          : 0.0.0.0
DHCP Client         : Enabled
CACHE               : Enabled
BL buffer base      : 0x00300000
BL buffer size      : 0x00100000
Baud Rate           : -1
USB Interface       : Disabled
Serial Number       : 0xFFFFFFFF


For help on the available commands type 'h'

Press ESC to enter debug mode ......
Cache enabled!
Processing image 1 ...
Executing image 1 ...
... and here it hangs.

I use following commands to write partitions:

Code: [Select]
fx 1 linux 0x7f020000 0x8000 -acx
fx 2 romfs 0x7F140000 0x7F140000 -a

After flashing, my partition table looks like this:

Code: [Select]
Press ESC to enter debug mode .....

bootloader > ls
Image: 0 name:BOOT INFO base:0x7F010000 size:0x00000038 exec:0x7F010000 -af
Image: 1 name:linux base:0x7F020000 size:0x00107900 exec:0x00008000 -acx
Image: 2 name:romfs base:0x7F140000 size:0x00135900 exec:0x7F140000 -a

My kernel and romfs are coming from:

Code: [Select]
        /usr/local/src/uClinux-dist-nuc700/linux-3.1/arch/arm/boot/zImage
        /usr/local/src/uClinux-dist-nuc700/romfs.img > romfs.img

Can anyone tell me what am I doing wrong?







Pages: [1]