News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Author Topic: How to identify which model  (Read 9871 times)

  • No avatar
  • *
June 23, 2014, 08:54:33 am
Does anybody know how to recognize which camera I have?  As usual, its a cheap chinese POS with no brand name on it.  The blue box says "ALL-IN-ONE IP/Network Camera".  The web gui lists "Software Version: 0.0.0.2" and "Web Version: 0.0.0.0.3" which I suspect is BS.  The internal DDNS is "nwsvr1.com".

The camera is running Linux and accepts a telnet connection with no authorization.  It lets me look at the file structure, but not at any files themselves.  I can do stuff like "cp" (copy) and "rm" (delete) on files, but "cat" (type) is missing.  There is a "type" command in the mini-busybox shell, but it doesn't seem to do much and wont type the file on the screen.  I tried "cp file con" and also "con:" and "con$" but none of that worked.  It just created a file called "con", etc.

When I first telnet in, the current directory is "/tmp/eye".

There is also an FTP server which also works, but the regular admin password does not work so I can't get in right now.

There was a little CD that came with the camera and on it there were instructions that called it a B1 camera 520 or 521.  I think that is some sort of generic name.

The web system primarily operates with XML files and not CGI as most here seem to do.  Entering "http://ip:port/videoinfo.xml" in firefox brings up:
<Result>
<Success>1</Success>
<CanConfig>1</CanConfig>
<Width>640</Width>
<Height>480</Height>
<Freq>0</Freq>
<HMirror>0</HMirror>
<VMirror>0</VMirror>
<Caps Mirror="0" LightMode="0"/>
</Result>

So basically anything that ends in ".xml" invokes an internal CGI script that handles access to the specified XML file.

In one of the web pages they have a section that suggests that the chip may be MIPS and not ARM.  There is a function that says "if (Board=="MIPS") ...", but I can't find anything that actually calls that function.

SO has anyone seen one like this?  Is it compatible with openipcam?




  • No avatar
  • *
June 24, 2014, 08:45:23 am
same here,
i also have same problem.
how to recognise camera make or popular clones?

any method to know hardware info ?

  • No avatar
  • *
June 24, 2014, 09:47:40 am
I think I could find out more about it if I could figure out how to view the files.  The standard Linux way is to use the cat command, but this is not supported by the busybox system on this camera.  Seems like there ought to be a way to do it with the copy "cp" command, but I haven't figured it out yet.

Can the echo command be used to view a file?

I've also been trying to figure out what password they are using for FTP access, with no luck.  Its not the same as the main login password.

I also found a file called ocx.exe in the www directory.

EDIT: I can see the filesystem, but still no way to view a file.
Quote
BusyBox v1.12.1 (2012-01-09 07:05:43 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

# mount
rootfs on / type rootfs (rw)
proc on /proc type proc (rw)
none on /var type ramfs (rw)
none on /etc type ramfs (rw)
none on /tmp type ramfs (rw)
none on /media type ramfs (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw)
none on /proc/bus/usb type usbfs (rw)
/dev/mtdblock5 on /tmp/eye type jffs2 (rw)
« Last Edit: June 24, 2014, 09:52:54 am by n4mwd »

  • No avatar
  • *
June 30, 2014, 08:41:12 am
UPDATE: I noticed when I FTP'ed into the camera that the welcome message contained a web address.
It was "http://www.maygion.com/en/index.htm".

So it would seem that these people are the manufacturers of this camera.  Unfortunately, it also seems to say that the processor is MIPS and not ARM so OPENIPCAM wont work.

Oh, well.