News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Author Topic: I deleted Image: 0 name:BOOT INFO. Could anyone send it to me.  (Read 55234 times)

  • *****
June 29, 2011, 02:47:03 pm
Estou curioso. Você está usando software de tradução de idiomas, como estou nesta comunicação? Percebo artefatos sintaxe da linguagem em suas comunicações.

---------

I am curious. Are you using language translation software, as I am in this communication? I notice language syntax artifacts in your communications.

June 30, 2011, 08:11:23 pm
Inglês:
Celem correct use Google Translator, so everything you write in English I use the translator to enter WHAT are saying, so sometimes gut out some letters. rs

Português:
Correto Celem uso o Google Tradutor, assim tudo que vocês escrevem em ingles eu uso o tradutor para enter oque estão dizendo, por isso as vezes sai umas letras entranha.
« Last Edit: June 30, 2011, 08:52:31 pm by casbeto »

July 01, 2011, 02:08:23 pm
Hi,

I've been monitoring progress between Admin, Casbeto and Celem about the problem Casbeto has with his cam. I've got exactly the same cam with the same problem. I managed to, sadly only briefly, get my hands on an identical working cam and dumped the linux.bin and romfs.img files using the Foscam Clone Recovery tool. I also made a copy of the normal succesfull boot sequence. Maybe this will help.

I failed in trying to reflash the broken cam with the dumped files from the working one. I keep getting an error that it is unable to unzip or an error that romfs is not loading.

see attached files.

@Admin: how can I upload the firmware files I dumped?

Regards,
John
« Last Edit: July 01, 2011, 02:13:13 pm by jjnh »

July 01, 2011, 02:11:43 pm
Small addition:

This is also a cam with ES_IP607_ARM_2 on the board.

July 01, 2011, 03:45:02 pm
Dear jjnh,

 You can post these files for me to try to recover my IPCAM?

 I'll try to tftp and how are the original files can work.

 I look back and thank you for trying to help me!
« Last Edit: July 01, 2011, 03:49:27 pm by casbeto »

July 01, 2011, 03:54:38 pm
Hi Casbeto,

The files are in the attached zip file.

I've tried them on my broken cam and they don't seem work  :(
Maybe you, or some of the experts on this forum, can get them to work so we can help each other 8)

Kind regards,
John

  • *****
July 01, 2011, 04:12:11 pm
casbeta, Você não relatou os resultados de minha sugestão de "29 de junho de 2011, 10:02:16". Volte e leia a minha sugestão anterior.

You did not report results from my suggestion of "June 29, 2011, 10:02:16 am". Go back and re-read my suggestion.

« Last Edit: July 01, 2011, 05:26:41 pm by celem »

  • *****
July 01, 2011, 04:15:46 pm
jjnh,

I recommend that you try the known good firmware files in the Files section of this website - http://goo.gl/29mq4 Your dump may have errors.

WARNING: Do not use these files unless your camera is a WansView NC-541/W


July 01, 2011, 06:26:47 pm
Dear Celem, you can leave before trying the tftp or her do the procedure, and put the result, then we see that has no solution, then I try the firmware that jjnh posted.

sds,
casbeto

  • *****
July 01, 2011, 06:41:30 pm
cabesto,

What I said was:

1. Your camera can correctly install and run a linux kernel and romfs directly to RAM.
2. All actions involving FLASH appear to fail.
3. The ls command shows "BOOT INFO" as mounted yet subsequent accesses indicate that it is corrupted.
4. Conclusion: your FLASH has a problem.

My final recommendation. If this fails, consider the camera a source of spare parts.

Using the bootinfo file previously posted:
http://goo.gl/7vQpV
enter the following commands:

DEL -all
DEL b1
fx 0 "BOOT INFO" 0x7F010000 0x7F010000 -f   (NOTE: on your PC xmodem send the bootinfo file referenced above)

July 01, 2011, 07:02:14 pm
here's the result!

WARNING: Image 0 was not found. Try to create one ...
.Image 0 created


W90P745 Boot Loader [ Version 1.1 $Revision: 1 $ ] Rebuilt on Dec 10 2009
Memory Size is 0x1000000 Bytes, Flash Size is 0x400000 Bytes
Board designed by Winbond
Hardware support provided at Winbond
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.


For help on the available commands type 'h'

Press ESC to enter debug mode ......
ERROR: Image 0 not found


ERROR: Data Abort @ pc=0x00001680
bootloader > del -all
Press Ctrl-c to stop
Deleting ... Block 2
Deleting ... Block 3
Deleting ... Block 4
Deleting ... Block 5
Deleting ... Block 6
Deleting ... Block 7
Deleting ... Block 8
Deleting ... Block 9
Deleting ... Block 10
Deleting ... Block 11
Deleting ... Block 12
Deleting ... Block 13
Deleting ... Block 14
Deleting ... Block 15
Deleting ... Block 16
Deleting ... Block 17
Deleting ... Block 18
Deleting ... Block 19
Deleting ... Block 20
Deleting ... Block 21
Deleting ... Block 22
Deleting ... Block 23
Deleting ... Block 24
Deleting ... Block 25
Deleting ... Block 26
Deleting ... Block 27
Deleting ... Block 28
Deleting ... Block 29
Deleting ... Block 30
Deleting ... Block 31
Deleting ... Block 32
Deleting ... Block 33
Deleting ... Block 34
Deleting ... Block 35
Deleting ... Block 36
Deleting ... Block 37
Deleting ... Block 38
Deleting ... Block 39
Deleting ... Block 40
Deleting ... Block 41
Deleting ... Block 42
Deleting ... Block 43
Deleting ... Block 44
Deleting ... Block 45
Deleting ... Block 46
Deleting ... Block 47
Deleting ... Block 48
Deleting ... Block 49
Deleting ... Block 50
Deleting ... Block 51
Deleting ... Block 52
Deleting ... Block 53
Deleting ... Block 54
Deleting ... Block 55
Deleting ... Block 56
Deleting ... Block 57
Deleting ... Block 58
Deleting ... Block 59
Deleting ... Block 60
Deleting ... Block 61
Deleting ... Block 62
Deleting ... Block 63

bootloader > del b1

bootloader > fx 0 bootinfo 0x7F010000 0x7F010000 -f
Waiting for download ...

  • *****
July 01, 2011, 07:03:52 pm
Você não seguir as instruções. Formulação do "INFO BOOT" importante. Leia atentamente as instruções.

You did not follow instructions. Wording of "BOOT INFO" important. Read instructions carefully.

July 01, 2011, 07:46:55 pm
I've done: del-all

 del b1, just missing the command below.

what should I enter?


 fx 0 "BOOT INFO" 0x7F010000 0x7F010000 -f

 fx 0 BOOT INFO 0x7F010000 0x7F010000 -f

 or

 fx 0 bootinfo.bin 0x7F010000 0x7F010000 -f
« Last Edit: July 01, 2011, 07:53:35 pm by casbeto »

  • *****
July 01, 2011, 07:54:55 pm
Exatamente como está escrito. Incluem pontuação.

Exactly as written. Include quotation marks.

fx 0 "BOOT INFO" 0x7F010000 0x7F010000 -f

What I said was:

1. Your camera can correctly install and run a linux kernel and romfs directly to RAM.
2. All actions involving FLASH appear to fail.
3. The ls command shows "BOOT INFO" as mounted yet subsequent accesses indicate that it is corrupted.
4. Conclusion: your FLASH has a problem.

My final recommendation. If this fails, consider the camera a source of spare parts.

Using the bootinfo file previously posted:
http://goo.gl/7vQpV
enter the following commands:

DEL -all
DEL b1
fx 0 "BOOT INFO" 0x7F010000 0x7F010000 -f   (NOTE: on your PC xmodem send the bootinfo file referenced above)

July 01, 2011, 07:59:07 pm

Deleting ... Block 62

Deleting ... Block 63



bootloader > del b1



bootloader > fx 0 "BOOT INFO" 0x7F010000 0x7F010000 -f

Waiting for download ...

do not get out of it!