News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Author Topic: I deleted Image: 0 name:BOOT INFO. Could anyone send it to me.  (Read 51851 times)

  • *****
June 26, 2011, 10:06:58 pm
Sorry, I misspoke - you cannot use the "e" command for this.

just enter SET with no arguments and post the output, as I mentioned before.

June 26, 2011, 10:44:01 pm
as you said the SET command is not accepted, I think my IPCAM really dead. thanks for any help.

 casbeto

  • *****
June 26, 2011, 10:55:34 pm
You have nothing to lose by deleting image 0 and rebooting to see if another rebuild goes better.
Code: [Select]
DEL 0

June 26, 2011, 11:01:16 pm
bootloader > ls
Image: 0 name:BOOT INFO base:0x7F010000 size:0x00000048 exec:0x7F010000 -f

bootloader > del 0
ERROR: Image 0 is not existed

ERROR: Data Abort @ pc=0x00001680
bootloader >
bootloader > boot

Rebooting the system ...

WARNING: Image 0 was not found. Try to create one ...
.Image 0 created


W90P745 Boot Loader [ Version 1.1 $Revision: 1 $ ] Rebuilt on Dec 10 2009
Memory Size is 0x1000000 Bytes, Flash Size is 0x400000 Bytes
Board designed by Winbond
Hardware support provided at Winbond
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.


For help on the available commands type 'h'

Press ESC to enter debug mode ......
ERROR: Image 0 not found


ERROR: Data Abort @ pc=0x00001680
bootloader >

  • *****
June 26, 2011, 11:12:20 pm
Certainly not behaving normally. Possibly you have a flash problem.

June 26, 2011, 11:20:25 pm
anyway thank you for trying to help me.

 I have to order one from china. rs

 have a great day.

 thanks
 Carlos Alberto
 (casbeto-Brazil)

  • *****
June 26, 2011, 11:21:33 pm
Final thought:
You could also try:
DEL -all (doesn't delete 0, but then maybe other errors are the actual cause)
 then try SET

DEL b1 (deletes the boot block)
 then try SET

  • *****
June 27, 2011, 12:03:33 pm
casbeto,

You can try to install my bootinfo image (attached to this post) To install, unzip the file and then enter:

fx 0 bootinfo.bin 0x7F010000 0x7F010000 -f

I have no idea if this will work, even in a normally functioning camera, because the uboot should have installed the boot image when it is missing. But, it's worth a shot - what have you got to lose?

June 27, 2011, 12:40:02 pm
At the moment I'm at work, so I'll try to get home and put the result to see you.

 worth friend, thanks for trying to help me.

June 27, 2011, 05:55:53 pm
Press ESC to enter debug mode ......
ERROR: Image 0 not found


ERROR: Data Abort @ pc=0x00001680
bootloader > fx 0 bootinfo.bin 0x7F010000 0x7F010000 -f
ERROR: Data corrupted, please check the free space of flash.

bootloader > del b0

bootloader > del b1

bootloader > deb b2
ERROR: unrecognised command

bootloader > del b31

bootloader > del 0
ERROR: Image 0 is not existed

bootloader > fx 0 bootinfo.bin 0x7F010000 0x7F010000 -f
Waiting for download ...

  • *****
June 27, 2011, 06:02:47 pm
Do this and then try again

DEL -all (doesn't delete 0, but then maybe other errors are the actual cause)
 then try SET

DEL b1 (deletes the boot block)
 then try SET

June 27, 2011, 06:17:10 pm
Deleting ... Block 61
Deleting ... Block 62
Deleting ... Block 63

bootloader > set
ERROR: Can't find image 0.

bootloader > del b1

bootloader > set
ERROR: Can't find image 0.

bootloader >

  • *****
June 27, 2011, 06:25:49 pm
did you then again try to load my boot image?

Sorry - i copied the message - the set would fail at this time. Try to load my boot image after the DEL -all and DEL b1

June 27, 2011, 06:32:17 pm
've tried everything!

 Deleting ... Block 61
 Deleting ... Block 62
 Deleting ... Block 63

 bootloader> del b1

 bootloader> fx 0 bootinfo.bin 0x7F010000 0x7F010000 -f
 Waiting for download ...
« Last Edit: June 27, 2011, 06:33:53 pm by casbeto »

  • No avatar
  • *****
June 27, 2011, 08:09:30 pm
Can you do an ls and show what partitions you have in the bootloader.

>ls

Paste the output.