News:

Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: I deleted Image: 0 name:BOOT INFO. Could anyone send it to me.  (Read 54290 times)

July 07, 2011, 04:25:49 pm
Here I am again ...  ::)

Just tried with firmware in nc54100417.zip.
See attached text file. Boot seems to go OK completely but ... it ends in myreboot  >:(

sw and as are both detected. Camera even starts to move for a second or two. If I keep IP Camera Tool open while the cam cycles the cam is even detected with the correct firmware. But immedatly fanishes when it reboots.

Any ideas?

Kind regards,
John

  • No avatar
  • *****
July 08, 2011, 02:37:57 am
did you allready try without LAN connection (you can reconnect when cam successfully rebooted)?
did you wait for several reboots and see if it will come up ok?
this is how mine started to die ...

July 08, 2011, 03:03:17 am
Hi Schufti,

Yep, tried all of that. No results.
I stopt it after about 40 or 50 reboots without the lan cable attached.

Regards,
John

  • No avatar
  • *****
July 08, 2011, 04:48:09 am
sorry, edited my post when you were answering ... now your post is a little confusing
(I asked jjnh to give a detailed situation and maybe open own thread)

as I see from various of your logs, you might want to try the "hootoo" fw I posted.
the various hw id's look similar to the ones from my (ex) cam.

In the end it had a similar behaviour with the former working apexis fw and worked solala with the original "hootoo" .... (I'm pretty sure it was an apexis clone because they'r the only ones with white LED I found)


p.s.: 1) dumping the webui wouldn't have "messed it up" dumping the flash can't harm anything
2) the idVendor = 0x148f, idProduct = 0x2573  only is the WLAN and of minor importance at the moment
3) what was the problem with the dumped fw? which errorlog?

the only indication on the cam chip I know of is the "detect_sensor: mi360" message
« Last Edit: July 08, 2011, 06:42:49 am by schufti »

July 08, 2011, 04:59:52 am
Hi Schufti,

Good idea however I don't think my problem is that much different than Casbeto's since the boards seem to be exactly the same.

Short situation sketch:

1. I have one broken cam
2. I borrowed a working cam that is exactly the same as the broken one. Same make, model, version, board, etc. I had to give back this borrowed cam because it was from a collegue that has left the company I work for. So I don't have access to it anymore.
3. Before I returned it, I dumped the boot sequence of the working cam
4. I also tried to dump the firmware (not the webui because I didn't want to mess it up) of the working cam
5. Restoring the dumped files does not work
6. Restoring CVLM-I33 firmware results in "aw not exists!"
7. Restoring nc54100417.zip results in correct boot but after 2 seconds it still does "myreboot"

That's where I'm at at the moment.

Kind regards,
John

P.S. At the moment I'm at work so I have no access to the cam.

July 09, 2011, 02:38:30 am
Hi Schufti,

Yep it's getting hard to follow. Almost missed your reply ...  ;)

Can you tell me where the "hootoo" firmware is? Couldn't find it in the firmware files.

Quick reply to your comments:
1. The webui.bin file was invisible and the firmware dump tool does not show hidden firmware. I'd rather not try to make it visible on the working cam.
2. OK to bad
3. I dumped the firmware using the windows tool. But when programming it into the broken cam, I get decompression errors. I also compared the memory sizes after flashing and they do not match. So I think the dumps are not ok.

There seems to be a newer firmware for EyeSight IP607 cam's (12.22.2.34/2.7.2.5). I tried to contact eyesight but they tell me the software is not available.

Cheers,
John

  • No avatar
  • *****
July 09, 2011, 04:58:50 am
Hi,
the hootoo fw didn't make it to the firmware .. it's here

  • No avatar
  • *****
July 09, 2011, 05:46:54 am

July 09, 2011, 10:40:36 am
Hi Admin and Schufti,

To bad. It doesn't work  :'(
I've attached the boot sequence.

Any other thoughts?

Kind regards,
John

July 09, 2011, 10:55:23 am
One thing I noticed in the different boot logs, is that only the working cam mentions: "detect_sensor: mi360  ???

All other boot's do not mention this sensor. Maybe this helps to narrow things down ... 

  • No avatar
  • *****
July 09, 2011, 12:03:12 pm
Hi,
the newer apexis kernel also shows the detection of mi360.

Did you try this fw without LAN connected?
Because everything looks exactly like mine when it started to die.
In the end it was only working when booted without LAN and reconected later or with WLAN.
the older (hootoo) fw was a little more "stable" and booted quite fast with WLAN.

I didn't try to mix hootoo kernel with apexis romfs ...

but I repaired your fw dump, see attachment


@admin: do the orig. foscams also have this one time i2c write error during boot?
Would be interesting what this i2c write should be doing. Obviously it doesn't matter for the real operation because I didn't see any malfunction other than the error messages and occasional reboots.
« Last Edit: July 09, 2011, 01:52:53 pm by schufti »

July 10, 2011, 10:18:41 am
Hello Schufti,

Yes your absolutely right. I looked it up in wrongboot4.txt.
I tried all rom's with and without the LAN connected.

It just seems as if this board only works with the exact same firmware as it comes with. The firmware for the CVLM-I33 in the archive, is older then the one on te working cam.

I've contacted my (ex) collegue to see if he is willing to temporary donate his working cam. How can the dump of the firmware be done right? Since the last dump was not succesfull.

Kind regards,
John

  • No avatar
  • *****
July 10, 2011, 11:17:02 am
just try to flash the repaired dump I attached to my last post ...

if possible use the method with kermit script and dump the whole flashrom.
We'll split it into needed parts later. so you'll get all the needed settings too.
« Last Edit: July 10, 2011, 11:21:40 am by schufti »

July 10, 2011, 02:59:12 pm
Woops. Missed the attached file. I'll try it now.

July 10, 2011, 03:28:17 pm
Hi Schufti,

Just tried the FW. Great work!! Looks like the linux boot and the firmware are completely the same. Great job!!! But ... still myreboot at the end :'(
I've attached the boot log. Just that I don't have the right webui. Since the webui is only a html file can this still lead to the myreboot?

I'm just wondering if the i2c writes don't indicate it's looking for something on the I2C bus that is not there anymore. like some pre-programmed eprom or something like that. Do you know what's on the I2C bus in these cam's? Only a memory chip or are there other components attached?

Do you know where the I2C lines are located? I've got a logic analyzer with I2C decoder so I could look at what's happening on the bus.

Cheers,
John