Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at

Author Topic: Camara ip607 chinavasion dead  (Read 8229 times)

July 28, 2011, 09:41:03 pm
Hi I have a camera ip607 foscam a clone. It worked well until one day I stop, connectivity and infrared light up only the green LED but does nothing.
 I accessed the camera for hyperterminal and says this:
 MAC Address: 00:0 C: 5D: 75:1 D: 5F
 IP Address:
 DHCP Client: Enabled
 CACHE: Enabled
 BL buffer base: 0 × 00300000
 BL buffer size: 0 × 00100000
 Baud Rate: -1
 USB Interface: Disabled
 Serial Number: 0xFFFFFFFF

 For help on the available commands type 'h'

 Press ESC to enter debug mode ... ...
 Cache enabled!
 Processing image 1 ...
 Processing image 2 ...
 Processing image 3 ...
 Processing image 4 ...
 Processing image 5 ...
 Processing image 6 ...
 Processing image 7 ...
 Unzip image 7 ...

 ERROR: unzip failed! -3


 As I can fix this problem? I've tried loading the firmware and linux but still the same, I think it's starting to be damaged, but not how to fix it nor do I have the files. Thank you.

  • No avatar
  • *****
July 28, 2011, 10:25:41 pm
How much ram, how much flash?

(first 2 lines in the boot loader message)

July 29, 2011, 07:25:30 am
W90P745 Boot Loader [ Version 1.1 $Revision: 1 $ ] Rebuilt on May 11 2010                                                                         
Memory Size is 0x1000000 Bytes, Flash Size is 0x400000 Bytes                                                           
Board designed by Winbond                         
Hardware support provided at Winbond                                   
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.

0 BOOT INFO 0X7F010000    0X00000038
7 0X7F020000    0X000BF780
6 romfs.img 0X7F0E0000    0X0008D000

These are the data. Foscam Firmware Recovery software will not let me do a dump of the image 0 BOOT INFO, the other if I can do a dump. Thanks

« Last Edit: July 29, 2011, 08:10:49 am by raben785 »

  • No avatar
  • *****
July 29, 2011, 09:43:36 am
Ok, so you have 16M ram, 4M flash

You don't need the boot info - its just for the boot loader, not for the OS.
Why don't you give my alpha firmware a try, and post a boot log, then I can see what hardware you have.

July 29, 2011, 10:41:56 pm
I do not understand very well that I say I what I have been charged to the firmware is in this direction, I followed the manual and I have the firmware for that ip607 is the model my camera. I do not know the alpha firmware you speak of. What I think is that the error is not recorded in the files in the correct place in the flash memory. Do you know if directions me where I have to burn the files correct? Like I have another camera, if I make a copy to your firmware and recorded on the camera damaged, it should work, right? Thank you.

July 30, 2011, 01:32:17 pm
Where I can download the alpha firmware and as I install it on my camera. Thanks

July 31, 2011, 09:37:34 am
The model of my motherboard is ES_IP607_ARM_2. I tried all the firmwares of the website and the answer is the same ERROR UNZIP -3. What I can do? What I'm not doing right? I'm doing as follows:
 del 7
 del 6

fx 7 0x7f020000 0x8000 -acxz
fx 6 romfs.img 0x7f0e0000 0x7f0e0000 -a

 del b31
 Error unzip -3
 Thank you.
« Last Edit: July 31, 2011, 09:55:58 am by raben785 »

July 31, 2011, 02:57:25 pm
I tried to install the alpha firmware and I could not, hyperterminal screen goes blank and I have to restart the camera.