News:

Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: DBPOWER VA035K Outdoor Wireless IP Camera  (Read 18412 times)

July 29, 2012, 12:06:52 pm
Hello everyone I buyed a cheap foscam clone from ebay with the name DB power.
After playing arround I'm very happy with the quality good wifi performance and strong build quality.

Searching on the we I found nearly nothing about the DB Power outdoor ip camera. I desired to start explore the device by my self.

First a console port for a bootlog there is a J2 But this is a USB port thats connect the camera!
No luck, there is an other two pair of 4 pins but it's serial 542 one connects the wireless card.

after searching a Nuvoton scheme i found uart0 as a console port but these not leading to a set op pins (i will make a picture to explane that)

After soldering and connect the serial port at 115200 i get a output:

Code: [Select]
W90P745 Boot Loader [ Version 1.1 $Revision: 1 $ ] Rebuilt on May 11 2010
Memory Size is 0x1000000 Bytes, Flash Size is 0x400000 Bytes
Board designed by Winbond
Hardware support provided at Winbond
Copyright (c) Winbond Limited 2001 - 2006. All rights reserved.
Boot Loader Configuration:

MAC Address         : 78:A5:DD:02:9F:B0
IP Address          : 0.0.0.0
DHCP Client         : Enabled
CACHE               : Enabled
BL buffer base      : 0x00300000
BL buffer size      : 0x00100000
Baud Rate           : -1
USB Interface       : Disabled
Serial Number       : 0xFFFFFFFF


For help on the available commands type 'h'

Press ESC to enter debug mode ......
Cache enabled!
Processing image 1 ...
Processing image 2 ...
Processing image 3 ...
Processing image 4 ...
Processing image 5 ...
Processing image 6 ...
Processing image 7 ...
Unzip image 7 ...
Executing image 7 ...
Linux version 2.4.20-uc0 (root@maverick-linux) (gcc version 3.0) #1482 ËÄ 6ÔÂ 16 01:00:08 CST 2011
Processor: Winbond W90N745 revision 1
Architecture: W90N745
On node 0 totalpages: 4096
zone(0): 0 pages.
zone(1): 4096 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/rom0 rw
Calibrating delay loop... 39.83 BogoMIPS
Memory: 16MB = 16MB total
Memory: 14616KB available (1278K code, 206K data, 40K init)
Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
Inode cache hash table entries: 1024 (order: 1, 8192 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
PTZ Driver has been installed successfully.
Winbond W90N745 Serial driver version 1.0 (2005-08-15) with no serial options enabled
ttyS00 at 0xfff80000 (irq = 9) is a W90N745
Winbond W90N7451 Serial driver version 1.0 (2005-08-15) with no serial options enabled
ttyS00 at 0xfff80100 (irq = 10) is a W90N7451
I2C Bus Driver has been installed successfully.
Blkmem copyright 1998,1999 D. Jeff Dionne
Blkmem copyright 1998 Kenneth Albanowski
Blkmem 1 disk images:
0: 7F0E0000-7F1EC7FF [VIRTUAL 7F0E0000-7F1EC7FF] (RO)
S29GL032N Flash Detected
01 eth0 initial ok!
which:0
PPP generic driver version 2.4.2
Linux video capture interface: v1.00
Winbond Audio Driver v1.0 Initialization successfully.
usb.c: registered new driver hub
add a static ohci host controller device
: USB OHCI at membase 0xfff05000, IRQ 15
hc_alloc_ohci
usb-ohci.c: AMD756 erratum 4 workaround
hc_reset
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver audio
audio.c: v1.0.0:USB Audio Class driver
usb.c: registered new driver serial
usbserial.c: USB Serial Driver core v1.4
rtusb init --->
usb.c: registered new driver rt2870
dvm usb cam driver 0.0.0.1 by Maverick Gao in 2010-8-3
usb.c: registered new driver dvm
dvm usb cam driver 0.1 for sonix288 by Maverick Gao in 2009-4-20
usb.c: registered new driver dvm usb cam driver for sonix288
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 1024 bind 2048)
VFS: Mounted root (romfs filesystem) readonly.
Freeing init memory: 40K
BINFMT_FLAT: bad magic/rev (0x74202d74, need 0x4)
BINFMT_FLAT: bad magic/rev (0x74202d74, need 0x4)
Shell invoked to run file: /bin/init
Command: mount -t proc none /proc
Command: mount -t ramfs none /usr
Command: mount -t ramfs none /swap
Command: mount -t ramfs none /var/run
Command: mount -t ramfs none /etc
Command: mount -t ramfs none /flash
Command: mount -t ramfs none /home
Command: mount -t ramfs none /tmp
Command: mkdir /tmp/run
Command: camera&
[8]
Command: sh

Sash command shell (version 1.1.1)
/> hub.c: connect-debounce failed, port 1 disabled
new USB device :80fb4004-fed6c0
hub.c: new USB device 1, assigned address 2
probing sonix288 usb camera ...
dvm camera registered as video0
p1[7]:1,j 3,config->bNumInterfaces:4
usbaudio: device 2 audiocontrol interface 2 has 1 input and 0 output AudioStreaming interfaces
usbaudio: valid input sample rate 16000
usbaudio: device 2 interface 3 altsetting 1: format 0x00000010 sratelo 16000 sratehi 16000 attributes 0x01
usbaudio: valid input sample rate 48000
usbaudio: device 2 interface 3 altsetting 2: format 0x00000010 sratelo 48000 sratehi 48000 attributes 0x01
usbaudio: registered dsp 14,35
usbaudio: warning: found 1 of 0 logical channels.
usbaudio: assuming the channel found is the master channel (got a Philips camera?). Should be fine.
usbaudio: registered mixer 14,32
usb_audio_parsecontrol: usb_audio_state at 00ff3e80
new USB device :80fb4404-fed6c0
hub.c: new USB device 2, assigned address 3
params length is 5428
sw version is 21.35.2.43
aw version is 0.0.3.18

Wait for auto-negotiation complete...ResetPhyChip Failed
video0 opened
1
1
1
1
1
1
unknown command
__pthread_initial_thread_bos:3f8000
manage pid:14
Prepare Audio Buffer
update_smarteye_ddns: can not get server www.db-power.com ip
ntpc.c: can not resolve ntpserver(time.nist.gov)'s ip
ntpc.c: can not resolve ntpserver(time.nist.gov)'s ip
Prepare Audio Buffer
ntpc.c: can not resolve ntpserver(time.nist.gov)'s ip
0x1300 = 00064300
inet_sr.c INET_rinput 321
action===1
options==33
inet_sr.c INET_setroute 75
*args===255.255.255.255
*args===netmask
*args===eth1
bonjour callback: service registered
ntpc.c: can not resolve ntpserver(time.nist.gov)'s ip
inet_sr.c INET_rinput 321
action===1
options==33
inet_sr.c INET_setroute 75
*args===default
*args===gw
*args===eth1
bonjour callback: memory free
bonjour callback: service registered
3
3
3
3
3
3
av client logon in 1186686722
update_smarteye_ddns: can not find content
av stop video 1186686722
av client logon in 1705054621

 ;D
Next step is getting a back-up off everything

July 29, 2012, 02:24:29 pm
I made a picture with the serial pins



 ;D

July 29, 2012, 03:34:16 pm
Here a youtube video from this camera

http://youtu.be/5PEF4-ll9CI

  • *****
July 29, 2012, 04:59:40 pm
Interesting. Have you tried to wire up the USB port to see what it can do?

July 30, 2012, 03:44:27 pm
No not yet first a back-up of the whole system.
But i think the usb connection can be used for other things like usb flash drive or something
the nuveton chip supports a serveral things of this.

But for now I have trouble to enter the debug mode. when booting the message "press ESC to enter debug mode" comes but when i press ESC nothing happens and the device is booting normal.

I'm using Putty to connect the serial. some people have a solution for this? please tell me how.

  • *****
July 30, 2012, 03:53:55 pm
Maybe the rx line needs a pull-up. Have you looked at the pin with a voltmeter and scope?

July 30, 2012, 04:34:45 pm
no not yet I haven't a scope only a volt meter.
do you mean by a pull up a 100 ohm resitor? i use them some times with jtag

  • *****
July 30, 2012, 04:46:01 pm
Yes, a resistor to pull the line to Vcc (+3 or +5, as the case may be)

July 30, 2012, 04:50:57 pm
ok  ;)

added a 100 ohm resistor but still can't enter debug like it's doing nothing with de commands I type strange?!

hmm 

July 30, 2012, 04:54:18 pm
with the volt meter I read 3.3V on both rx and tx

  • *****
July 30, 2012, 05:14:59 pm
If you send a continuous character stream while watching the voltmeter. The voltage should drop below 3.3V, possibly as low as 1.5V, depending upon the character used. A CR should suffice. If you see no voltage change, at all, then you are not transmitting.

July 30, 2012, 05:39:21 pm
I get no voltage change at all.
i'm not getting why because is used my usb to serial ttl interface for a bunch of other devices with no problem.

my serial all in one interface
http://www.nbglin.com/485.htm

  • *****
July 30, 2012, 06:06:26 pm
Your device uses 5V TTL logic but your chip is 3.3V. You need a diode to isolate the 5V. Hopefully no damage has already been done to the 3.3V Rx circuit. See the attachment for an example.

  • No avatar
  • *****
July 31, 2012, 06:00:23 am
If you can receive characters, the Tx pin of the cam (the only one possibly in need of a pull-up) has the correct levels.

If you can't send to the cam, it is not likely a pull-up/down problem as the ic's commonly used have correct push/pull output (not open collector).

As in you case, it seems you're not on the correct pin. The red wire goes to a pin that I would identify as Vcc. See the litte 103 marked resistor above? That is the pullup for the Rx-pin of the cpu. I suggest to use the left side of this resistor to connect the red wire once you fixed the 5V/3.3V problem....

and anyway, 100 Ohm is way too low for cmos semiconductors. IF there is need for pull-up/down then it is in the region of 4k7 to 10k as in the circuit mentioned by celem.

sidenote: in this circuit the arduino side would be your cable, the M32 side the cam... the diode should be a shottky or germanium type (fast, with low voltage drop)
« Last Edit: July 31, 2012, 06:22:11 am by schufti »

November 12, 2012, 04:00:12 pm
Hello all,

today i m back on my ip cam with a working connection both sides.
And I m busy with the backup now.

When its done I wil show you.

serial problem solved with using a normal pc instead of a laptop.