News:

Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: Firmware for EasyN FS-603A-M106  (Read 16905 times)

May 06, 2012, 05:39:45 pm
Hello!

I just updated my EasyN FS-603A-M106 old original firmware to firmware from Foscam FI8904W. Everything works much better except there is no more wireless connection. When I press scan button in web gui, it doesn't return any results and also wireless LED isn't blinking anymore on wireless plate.

I don't have original firmware, so I was thinking maybe you can suggest me smth.


Thank you!
« Last Edit: May 06, 2012, 05:51:30 pm by SoWhat »

  • *****
May 06, 2012, 06:05:53 pm
As far as I can tell, there is no firmware in the FIRMWARE section of this website for the EasyN FS-603A-M106. There is some firmware for the EasyN FS-613A-M136 which might work better for you than Foscam firmware.

Why did you put Foscam firmware into an EasyN camera? Your probability of failure is close to 100%. WiFi and image sensors vary considerably between cameras.

Final thought: Contact EasyN tech support and tell them what you did. For me, they have been responsive and forthcoming with replacement firmware.
Support E-mail: support@easynp.com.cn
« Last Edit: May 06, 2012, 06:17:17 pm by celem »

May 07, 2012, 02:07:16 am
Thanks for replay celem!

I did this because original firmware had some bugs - no e-mail function and no motion detection was working correctly. And there is no FW update available for my EasyN. I was trying to contact EasyN TechSupport almost a year without any luck, but I was writing to them from their website. Didn't know their e-mail, so thanks for it!

Foscom camera is very similar to my EasyN, probably that's why Foscom Firmware works almost perfect (much less bugs and new cool features are available there), only one problem with wireless :)

I took a look at firmware you suggested. As I understand from readme.txt, you are using some advanced technics for uploading it. Can you please tell me where can I find info about this flashing method? Are you using some micro controller programming interface or what?


EDIT: EasyN support sent me updated firmware. They replay to e-mails very quickly :) But wireless still doesn't work even on original FW. Could it be that Foscam firmware has damaged wireless chip?

EDIT2: I checked wireless plate with tester and I found that there is bad connection between main plate and wireless plate. So it looks like Foscam FW wasn't one to blame.

EDIT3: I fixed connection and I am thinking about putting back Foscam FW, because new updated EasyN firmware has less features. Here's my fix:
« Last Edit: May 07, 2012, 10:28:00 am by SoWhat »

  • No avatar
  • *
December 18, 2013, 01:13:30 pm
Tony
Hi, im has bricked my camera, when i flash new firmware, my camera doesn't work, no self test, and no conect. How i can repair it?

support@easyn.com
hello
  so now when you connect your camera with cable and power adapter,and the camera cant do self-test,right,and the two lights near by the LAN cable,whether one light is blinking,one light is bright.of course,if you really need to do maintain,you can contact the business  personnel who will support the corresponding procedure about this.

Tony
How I can contact him? Or where I can find him? I tried to reboot Linux and romfs with j2tag, but it not help, I think I can't find good Linux and romfs.

support@easyn.com
hello
  please contact the one who sell you the camera.do hope you can understand.

Tony
I can't, I didn't know who seller, it's a gift. Why you cannot help me?

support@easyn.com
hello
  how do i help you.cause it is the problem of hardware,so if there is something i can do for you,i'm ready to help you.but currently,if it is the problem hardware,i don't know how to help you.cause the camera need to be maintained and checked.

Tony
Ok, can you please send me good framework with linux, romfs and boot info?

support@easyn.com
hello
   sorry,i couldn't do that.and those information is our company's develop program,do hope you can understand.