News:

Re-organized the forum to more cleanly delineate the development section, as the end user support side appears to have taken a life of its own!

Author Topic: Can't connect to IP Camera (firmware by MayGion) bought on Dealextreme SKU#29014  (Read 78017 times)

June 14, 2013, 03:20:36 pm
i have the same model "IP-CAMERA-ID002" but don't have board.dat how can i get one?

  • **
June 14, 2013, 06:38:48 pm
According to the MayGion website, the file comes with the camera and is unique to each device.  I don't know what its purpose is, or whether the camera will work without it.  I would suggest just ignoring it unless you are actually having problems and everything else seems fine.

July 04, 2013, 01:15:25 pm
The best thing to do is to identify whether your Maygion cam is using a ARM or MIPS core.

for MIPS this is the best TS guide: http://www.maygion.com/downloads/20110927/ipcam_mips.htm

Your device is probably like the one I purchased, mine is MIPS.


September 09, 2013, 03:55:39 pm
My ipcam is bricked and I'm looking for the file "ldr". I have access to the camera via ftp (192.168.1.111. Anyone can upload it?

Thanks.

September 10, 2013, 11:45:39 am
Here's my ldr file, but I have currently bricked my maygion camera. Frustratingly I did manage to fix it the other day and accidentally deleted the cs binary so bricked it again. Now I can't worked out which of the many firmware revisions I've downloaded from the maygion site.

NB, when using ftp on the command line I couldn't see the ldr, but telnet'ing shows the file and I was able to get the file even though it wasn't showing.

HTH
Dan

if I can work out the firmware that fixes it I'll report it here.

September 10, 2013, 01:20:51 pm
Hi all.

Had an issue with regards to an issue of an IP-Camera that just won't start.  Even if the files in /tmp/eye/ are returned with original files.  I was dumb enough to delete the whole /tmp/eye directory.

WARNING: Do not delete folders or any other files other than those in /tmp/eye/app or /tmp/eye/www

When the /tmp/eye directory is removed instead of just the files in /tmp/eye/app or /tmp/eye/www, this creates an issue where script file (/tmp/eye/init.sh) will not have execution rights.  There is also a hidden file called "ldr".  Luckily the IP-Camera FTP seems to give files without an extension execution rights.

To resolve the issue, follow the following steps:

  • Download the ldr file from https://rapidshare.com/files/2539309861/ldr
  • Download the /tmp/eye/init.sh file via FTP from your IP-Camera
  • Delete the /tmp/eye/init.sh file from your IP-Camera
  • Rename the copy on local PC from init.sh to init
  • FTP the init file back to /tmp/eye/ on your IP-Camera
  • On your IP-Camera rename /tmp/eye/init to /tmp/eye/init.sh
  • Copy the ldr file from your local PC to /tmp/eye/ on your IP-Camera

Kind regards.... ;D

The problem is that I deleted this file init.sh and i can't restore it back my mips ip came can be connected to ftp server and the EYE folder still exist I don't know what to do could some one provide me with this file init.sh

September 10, 2013, 02:51:49 pm
https://dl.dropboxusercontent.com/u/18187990/init.sh

This is my file init.sh (if it helps someone).
I need the file "ldr"


September 10, 2013, 03:05:40 pm
https://dl.dropboxusercontent.com/u/18187990/init.sh

This is my file init.sh (if it helps someone).
I need the file "ldr"
Thank u I upload it but it didn't work
I'm trying to connect with maygion website to help me

But I a'so didn't find the ldr and i don't know what to do :(

September 10, 2013, 05:15:00 pm
I'm desperate. I'm trying to upload the ldr file, but the file disappears.

If the file is hidden I'm not getting to see it with any ftp client.

September 11, 2013, 05:01:18 am
You say the file disappears after uploading? I wasn't able to see the file either but I was able to GET it via ftp so I would guess PUT also works. If you telnet to the camera do you see the file?

Code: [Select]
telnet 192.168.1.111
Trying 192.168.1.111...
Connected to 192.168.1.111.
Escape character is '^]'.



BusyBox v1.12.1 (2012-01-09 07:05:43 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

# pwd
/tmp/eye
# ls -l
-rw-r--r--    1 0        0             527 Apr 21  2013 ldr.ini
-rwxr-xr-x    1 0        0              61 Jan  1 00:31 init.sh
drwxr-xr-x    3 0        0               0 Jan  1 00:02 www
-rwxr-xr-x    1 0        0          145844 Jan  1 00:00 ldr
drwxr-xr-x    2 0        0               0 Jan  1 00:00 app
-rwxr-xr-x    1 0        0          141632 Apr 17  2011 fd

From there I see the ldr file, but from ftp I don't see but it is still there so you may want to check with telnet to confirm it.


Code: [Select]
Connected to 192.168.1.111.
220 IPCamera FtpServer(www.maygion.com),do NOT change firmware unless you know what you are doing!
Name (192.168.1.111:username): MayGion
331 need password
Password:
230 login ok
ftp> pwd
Remote directory: /tmp/eye
ftp> ls -l
227 Entering Passive Mode (192,168,1,111,15,160).
150 Opening ASCII mode data connection for directory list.
226 Transfer complete
ftp> ls
227 Entering Passive Mode (192,168,1,111,15,161).
150 Opening ASCII mode data connection for directory list.
drwx------ 1 user group              0 Jan 01 00:00 app
drwx------ 1 user group              0 Jan 01 00:02 www
-rwx------ 1 user group             61 Jan 01 00:31 init.sh
226 Transfer complete
ftp>

September 11, 2013, 10:25:47 am
I can't telnet to the ip camera

September 11, 2013, 11:05:47 am
I've just managed to recover my camera by ftping the right combination of cs binary and www directory.

In the end the version that I used was: firmware.2013.04.22(h.264).rar from the Maygion site which reports softversion=00.00.05.53

Dan

September 12, 2013, 09:03:47 am
I have tried putting several versions but still not working ip camera web access. I always get the IP 192.168.1.111

In this thread I uploaded photos of the PCB to see if anyone knows where the RX and TX connectors.

www.openipcam.com/forum/index.php/topic,666.msg3342.html#msg3342

October 20, 2013, 01:20:45 pm
Hi fjanula,

I have the same problem, i trying to upload init.sh with a lot of client (filezilla, lftp, tnftp, cuteftp for mac) without results,
I try upload init.sh renamed to init and before upload rename, but not luck.

Finnaly, i resucite my ip cam upload init renamed file with CuteFTP 9 for Windows (for Mac no run) and then rename to init.sh in CuteFTP connected to cam.  ;D
I used firmware 3.1 files (www and app folder) to boot first time and then try another.

  • No avatar
  • *
March 04, 2014, 09:25:47 am
I delete accidentaly the ldr file from \tmp\eye. Can someone send it to me or upload anywhere?
Without the file I cannot make the camera works.
Thanks!