News:

Registered a URL and setup a forum as the IPCam stuff really needed its own site vs my irregular blog posts about IPCam hacking at http://www.computersolutions.cn/blog

Author Topic: newbie: help to access to a new cam ...  (Read 4787 times)

  • No avatar
  • *
January 10, 2015, 10:17:20 am
Hi to everybody,

I am newbie on these topics but few days ago I bought a chinese IPcam.
It seems all to run well but and I am able to look clearly the videostream either by my PC/Mac or my mobile devices .
Of course, it runs only by "SYSM Monitor" found on the intallation CD-ROM or by installing plug2view.apk on Android devices.
As I'm interested to use this camera also my Qnap SS over my home LAN I tryed to configure the camera without success. QNAP SS tries to detect by uPNP and by ONVIF with no successor maybe does not reach the camera ip address at all). The strange thing is that I am able to ping it but trying by an internet browser I am not able to access it.
The port used seems to be #5000 (not modifiable).

Tryed everithing:

-used unsuccesfully some scanning/discovery tools (both for mobile devices or for PC) to discover the right port but all these SW are not able to recognize the Cam (only Android "Evercam Discovery" finds a unknown device manufactured by Sperian Protection Intrumentation even though all other parameters are not recognized as well as the hardware is not recognized like a IPCam)
-trying to change the ip address and even using the DHCP


Please, any support/tips

Thank you,
auato


  • No avatar
  • *
January 11, 2015, 10:41:42 am
You can use nmap to discover open ports from Kali dstrib or Windows.

  • No avatar
  • *
March 21, 2016, 02:26:34 pm
have you found a way to access it? specific port etc...

  • No avatar
  • *
April 29, 2016, 03:51:44 pm
Hi,

long time lurker, first time poster :-).

I've 4 of these cams (damn), on eBay seems the cheapest (< 30$).

They have only port 23 open.

Two cameras have the same packaging but one (white model) have MAC starting 00:14 (S-TEC eletronics) the other (black model) MAC 00:15 (BETA tech).

Trying to connect MAC 00:14 the telnet promp looks like
Code: [Select]
root login:
Trying to connect MAC 00:15 the telnet promp looks like
Code: [Select]
(none) login:
The paper manual points to this site http://www.scc21.net/ for web access.

No luck login in through telnet using
root:root
admin:admin
root:admin
admin:root
admin:123456
root:123456

Update 2016-05-01
SoC is RT5350F

Now and then camera broadcasts (255.255.255.255 and 192.168.0.255) this to network
MainCmd=LocalData;bootproto=static;dns0=192.168.0.1;dns1=;netmask=255.255.255.0;netwet=192.168.0.1;userType=312;status=2;ver=820;index=0;lanport=5000;wannetable=0;errorcod=200;EnableSD=0;MoveRec=0;OutMoveRec=0;AutoRec=1;LoopWrite=1;Splite=50;AllSize=0;HaveUse=0;LeftSize=0;sdAudioMux=0;SDRecQC=1;devid=E150XXXXX;Psw=16216015546909088171

devid is the same printed on the side of the camera (obscured for privacy)

Psw is the same for all the 4 cameras I have.

Related to post
http://www.openipcam.com/forum/index.php?topic=760.0

Interesting post
http://jumpespjump.blogspot.it/2015/09/how-i-hacked-my-ip-camera-and-found.html

Another interesting post
http://jheyman.github.io/blog/pages/VideoSurveillance/
« Last Edit: May 09, 2016, 03:56:19 pm by nothinghood »